Skip to Content
0

Compilation errors while building Agentryclient for Android with arcGIS

Sep 29, 2017 at 10:16 PM

95

avatar image

Hi,

I am using eclipse neon3 to build an Agentry client for Android following the steps in SAP Help to build Android client with GIS

Below are the versions we download:

Agentry SDK - SP15 PL7
GIS SDK - 51051404_1.zip
ESRI SDK - arcGIS Runtime SDK for Android 10.2.9

However upon importing the first 2 projects 'AgentryAndroidClientSolution' followed by 'AgentryAndroidClientResources' I have received compilation errors that 'AgentryAndroidClientResources' is missing required Java project 'AndroidOpenSource'; 'Codeus','polidea_treeview' .

After this tried to import the library 'MobileAppsGIResourcesLibrary' but it produced an error that it is missing a requiredsource folder 'gen'. Also it is not able to be referenced as a library from 'AgentryAndroidClientSolution' as per the instructions.

Any help on this is appreciated.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Best Answer
Bill Froelich
Oct 02, 2017 at 09:11 PM
0

Starting with SP15 the Agentry Android client moved over to Android Studio for building the client. Please make sure you are using that instead of Eclipse for building the client now. I don't know if that has any impact on the ESRI SDK stuff but for the base client you should make the switch.

--Bill

Share
10 |10000 characters needed characters left characters exceeded
Hajira Syeda Oct 04, 2017 at 01:25 PM
0

Thanks Bill.

I have begun the process of building the Agentry client for android studio. However since I'm new to the tool, are you aware of any documentation that details the step by step process for this build using Android Studio. All the documentation I have found so far is only pertaining to the Eclipse tool using ADT.

Share
10 |10000 characters needed characters left characters exceeded
Hajira Syeda Oct 05, 2017 at 03:10 PM
0

Hi Bill,

I was able to import the AgentryAndroidClientSolution and related projects into Android Studio. However when I add the below line to build.grade file of the project:

dependencies {

// Add ArcGIS Runtime SDK for Android dependency

compile 'com.esri.arcgis.android:arcgis-android:10.2.9'

}

I get a build error that the location 'com.esri.arcgis.android:arcgis-android:10.2.9'could not be resolved. This is despite the URL https://esri.bintray.com/arcgis' being included under the maven repositories code block inside the application's build.gradle file.

Additionally tried installing the "arcgis-android-10.2.9.aar" file as a local M2 repository inside my user directory; but still the same build result occurs.

Due to this the open UI control for the map is not displaying in the Locations tab of the newly built Agentry client for Android.

Your help is highly appreciated.

Thanks.

Share
10 |10000 characters needed characters left characters exceeded
Subash Narayan
Oct 13, 2017 at 02:20 PM
0

Hi Hajira,

This will be answered through the support incident.

-Subash

Share
10 |10000 characters needed characters left characters exceeded