Skip to Content
0

Increase maximum data points visualization in SAP Lumira Server for Teams

Oct 13, 2016 at 01:14 PM

423

avatar image

Hello

Please, how can we increase the maximum data points visualization in SAP Lumira Server for Teams? Since it doesn't have a SAPLumira.ini file, I don't know how can we change it. I did some research in the Internet, but I couldn't find any information about it.

Thanks in advance,

Best regards,

Leonardo Frossati

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

avatar image
Former Member
Oct 13, 2016 at 08:23 PM
0

Hi leonardo,

You can by following Kbase https://apps.support.sap.com/sap/support/knowledge/public/en/2271815. Just a note that some chart types may have a maximum about that is hard coded in the chart and that the current limit set is there for stability reasons. Increasing this may cause instability of the server, slow the server down and consume more memory.

Kind Regards,

Trevor Dubinsky

Share
10 |10000 characters needed characters left characters exceeded
Leonardo F. Frossati Oct 13, 2016 at 08:51 PM
0

Hi Trevor,

Thank you very much. I tried to do it, but it seems to work only with SAP Lumira Server for BI. Since we don't have the CMC with SAP Lumira Server for Teams, I still don't know how to change it. Maybe I have to open a Ticket with SAP about it.

Kind Regards,

Leonardo Frossati

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member
Oct 21, 2016 at 12:04 AM
0

Hi Leonardo,

It took a bit to look into this. I think I may have an answer to this one. What I think you need to do is:

1 - Go to <Install Directory>\SAP Lumira Edge\Lumira Edge\win32_x86\smartservers\ServiceContainers

2 - Make a back up of TeamServerServiceContainer_dft.xml

3 - Edit TeamServerServiceContainer_dft.xml; I recommend something like notepad++ that can handle formatting and longer lines

4 - Search for: <property name="SI_ARGS"

5 - At the end of this line before </property> add the parameter so it looks similar to this (the end part only):

... "-XX:-UseSplitVerifier" "-Dhilo.recordsview.maxcells=<value>" "-Dhilo.maxvizdatasetsize=<value>"</property>

6 - Save the file and reboot your server

I do want to give you the following warnings:

- This may not work, if it doesn't it is because it is most likely not supported with the team server edition.

- Any patch install will very likely undo this change

- Altering these parameters may decrease your systems performance. The default values are there because they are recommended by our developers

- If you run into performance issues please remove these parameters

- Some visualizations may have their own hard coded values that cannot be over written.

Kind Regards,

Trevor Dubinsky

Share
10 |10000 characters needed characters left characters exceeded
Leonardo F. Frossati Oct 21, 2016 at 01:18 PM
0

Hi Trevor,

I also opened the ticket 356042/2016 for this subject, and Paul from SAP mentioned your help above in this ticket. Thank you very much.

I did what you suggested, then rebooted the server, but I still receive the same error message. Maybe it's something hard coded in the table component, but it would be strange, since I don't have any issues using the same data, components and visualization while using the SAP Lumira Desktop.

Best regards,

Leonardo Frossati

,


Share
10 |10000 characters needed characters left characters exceeded