Skip to Content

Could not get Development Configuration. Landscape Directory seems to be inconsistent

Hi,

We just experienced this issue recently. When we tried to import Development Configuration into NWDS, we got the error "Could not get Development Configuration. Landscape Directory seems to be inconsistent."

NWDI-DTR/CMS (v.7.01.10): we have our tracks and they work fine.

NWDS (v.7.01.10): we can see the Development Configuration with dev/cons tracks from NWDI. It logs into SLD properly.

SLD (v.7.40): it works fine; although I'm not sure what I should look for here. We have the latest CR Contents (as of Dec.2016). I even repaired the CR Contents but still got the same error.

The only thing I can see is that the list of Development Configuration in SLD is empty (nwa: Configuration -> Infrastructure -> Development Infrastructure). But when I tried to create new ones then they will show up in NWDS as new configurations in addition to our existing ones. How can I get our existing configurations to show up in SLD? It's been a while and I don't remember having to set up the Dev Conf in SLD. They were setup in NWDI (CMS - Landscape Configurator).

The only relevant discussion I found was an old thread

https://archive.sap.com/discussions/thread/600324

and the original poster (Leo van der Prijt) mentioned 're-associate' the tracks to solve the issue but I have no idea what he was talking about.

Any help/advice is greatly appreciated.

Regards,

Dao

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Oct 04, 2017 at 04:05 PM

    Hi Milen,

    Thank you very much for looking into this. I really appreciated it.

    I checked and we do have a matching Domain ID/Name/Description between CMS and SLD in both classes Change Management Server and Change Management Server. I even re-saved the domain data in CMS but, unfortunately, still got the same error.

    In the mean time, I kept digging and found out what 'associations' I need for my track:

    In the SLD: Administration --> Maintenance --> CIM Instances

    Subset: Classes With Instances

    Class: Design Time Configuration

    Here I can see all the tracks defined in CMS (both _cons and _dev for each track). Select each configuration (I can see that I have no associations) --> Associations tab --> New Association

    Association Type: CMS Maintained Configuration

    Associated Class: Change Management Server

    --> select the CMS server --> click on Associate

    and voila!

    I can now import the Development Configurations in NWDS!!!

    My issue is resolved. I just wanted to share the steps here in case someone else needs them.

    Regards,

    Dao

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 03, 2017 at 10:07 AM

    1. On CMS domain data tab in landscape configurator under "Domain" heading,

    Make note on
    Domain ID
    Domain name
    Domain description

    2. Log onto the SLD using the url maintained in "external servers" of CMS domain data tab
    on 7.00 SLD go Administration -> Content maintenance
    Subset: All with instance and class :Change Management Server
    check the value for the "name" column. The name must be the same as the one
    maintained in "Domain name" field that we noticed from step 1.

    3. If for some reason the entry is wrong then resaving the domain data in CMS will
    resolve the issue. With this CMS reregistered itself in SLD and recreated a correct
    and working 'Change Management Server' entry

    Add comment
    10|10000 characters needed characters exceeded