Skip to Content
avatar image
Former Member

"msg":"Device xxx] not found in registry. Synchronizing with RDMS. Processing delayed"

I am trying to send data from a device into cloud platform, but it is returning the message "msg":"Device [c115c920-1695-4908-a7bf-a4ef62201458] not found in registry. Synchronizing with RDMS. Processing delayed".

Initially it was telling me that it could not find the message type id for my device, and after finding no issues with that, I restarted the iotmms service and got the device not found in registry error. I recreated a new device, complete with new message type, and device type, but I am still getting this "Device not found in registry" error.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

9 Answers

  • Best Answer
    Oct 10, 2017 at 12:19 PM

    Dear users,

    Connectivity Service is back to normal and is able to handle destinations with "OnPremise" proxy type correctly again. Hence, a workaround of setting "Internet" proxy type for your "rdms" destination is not required anymore. However, "iotmms" needs to be re-started to get the the fixed Tomcat Runtime.

    Sorry for the inconvenience,

    Anton

    P.S. Kudos go to Former Member for finding a temporary solution.

    Add comment
    10|10000 characters needed characters exceeded

    • Hello Anton,

      Thanks for replying. We have raised a Medium Customer ticket. Can someone please have a look into it?

      Ticket Details - 487556 / 2017 Error in IoT-MMS service. Device not found in registry.

      Regards,

      Vikrant

  • avatar image
    Former Member
    Sep 29, 2017 at 08:41 AM

    Hi Just found the solution, in your java application go to destinations. There would be two destinations, iot cockpit and rdms, for both of them make proxy type as "internet". Save it, and then check connection. If its successfull, please restart the application and check http post after 5 minutes.

    Rewards points if useful

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Same issue on hanatrial. Setting the proxy to internet worked here as well. Thanks for saving my day.

      (When restarting iotmms service however it is reset to the original settings: therefore the only option for me was to change settings without restart and wait for 5 minutes.)

  • avatar image
    Former Member
    Sep 27, 2017 at 09:07 PM

    Very strange behaviour, I have created another account and I have tried the same steps and it works.. Please advise.

    The MMS URL for the non-working account is: iotmmsp1942939469trial.hanatrial.ondemand.com

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 28, 2017 at 06:35 PM

    Hi Jathavan Arumugam,

    I am facing similar issue, were you able to resolve it?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 29, 2017 at 06:52 AM

    Hi Jathavan,

    I am facing the same error, I tried with three different account and the error appears in all of them.

    How did you fix it?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I think that it is due to rdms destination, its not available when you check it. can you check your rdms destination within iotmms java application?

  • Oct 03, 2017 at 01:26 AM

    Hi,

    Fernando Here with the same problem. Have anyone found a solution?

    Thanks,

    Regards.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 01, 2017 at 05:23 PM

    Hi Ali,

    I´m facing the same issue since I restarted MMS, Device worked ok til yesterday, then I stopped and started MMS and now I have the issue,

    Device [....] not found in registry. Synchronizing with RDMS. Processing delayed

    If I check RDMS connection in IOTMMS destinations then I get this error message:

    Failure reason: "Backend is not available in the list of defined system mappings in Cloud connector"

    were you able to resolve it?

    Regards, Nacho

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Ignacio,

      yes I had a similar issue, answer has been mentioned above. In short, you have to change proxy type to Internet from on Premise for rdms and IoT cockpit destination. Details have been mentioned above.

      Regards,

  • avatar image
    Former Member
    Oct 05, 2017 at 09:11 AM

    It works in my productive account, I just have this issue in my trial account. Any ideas?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 05, 2017 at 09:11 AM

    It works in my productive account, I just have this issue in my trial account. Any ideas?

    Add comment
    10|10000 characters needed characters exceeded