Skip to Content

SLD server access settings

Hi all,

I have a problem whit the configuration on ABAP side for accesing to SLD. The SLD is installed on a different machine than SAP PI.

I have done the configuration on transaction SLDAPICUST in SAP PI machine an also created the RFC destinations requiered.

When I run SLDCHECK I get the next error:

Properties of RFC destination SAPSLDAPI

RFC host:

%%RFCSERVER%%

program id: SAPSLDAPI_MP1

gateway host:

acacia.everis.int

gateway service: sapgw00

Testing the RFC connection to the SLD java

RFC ping was successful

SLD server access settings:

host name: sld

port number: 50100

user :

Use transaction SLDAPICUST if you wish to m

Launching the SLD GUI in a separate browser

=> Verify in the browser GUI that the SLD i

Calling function LCR_LIST_BUSINESS_SYSTEMS

Retrieving data from the SLD server...

Function call returned exception code 4

=> Check whether the SLD is running!

What I found very strange is that in the server settings doesn´t appears the user I have write on SLDAPICUST.

SLD server access settings:

host name: sld

port number: 50100

user :

Moreover I have change the parameters required in SLDAPICUST and (host name vs IP, different user, .....), an run SLDCHECK and the SLD server settings are not change. Always appears the same SLD server access settings.

SLD server access settings:

host name: sld

port number: 50100

user :

Any idea about this behaivour?

Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Oct 31, 2007 at 08:48 AM

    hi

    if it is pi system then you need to run the templates in NWA.

    if your not clear with this write to krushi.sakriya@logicacmg.com

    regards,

    KRUSHI

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      hi,

      go to the function module se37 you can debug there.

      check it PIAPPLUSER Is locked or not.

      when you open the SLD use PIAPPLUSER creditials and login.

      regards,

      KRUSHI

  • avatar image
    Former Member
    Oct 31, 2007 at 08:49 AM

    Hi,

    Check whether the following RFC destinations are created or not on PI.

    Following were the list of RFC Destinations created during post installation configuration. Their relevance are as follows:

    AI_RUNTIME_JCOSERVER

    Points from the Integration Server to the mapping runtime. The program ID corresponds to the entry under JCo RFC provider for the J2EE Engine (used for the mapping runtime, value mapping, and the exchange profile).

    AI_DIRECTORY_JCOSERVER

    Points from the Integration Server to the Integration Builder. The program ID corresponds to the entry under JCo RFC provider for the J2EE Engine (used to refresh the runtime cache).

    LCRSAPRFC

    The RFC destination LCRSAPRFC is required for the connection to the System Landscape Directory (SLD). It is used to read the exchange profile.

    SAPSLDAPI

    The RFC destination SAPSLDAPI is required for the connection to the SLD. It is used by the ABAP API.

    INTEGRATION_DIRECTORY_HMI

    For Cache Updates

    Refer link for more details:

    http://help.sap.com/saphelp_nw04s/helpdata/en/be/6e0f41218ff023e10000000a155106/content.htm

    In order to have a connection between R3 and SLD you need to create the RFC destination at the R3 side also.

    LCRSAPRFC

    SAPSLDAPI

    Thanks and Regards,

    Chirag Gohil

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Antonio Sanz

      hi

      have you resolved the problem of error return code.

      ara you getting all business system in your sld check.

      if it is not fellow the procedure what i have given,

      regards,

      KRUSHI

  • avatar image
    Former Member
    Oct 31, 2007 at 08:49 AM

    Follow the Problem Analysis guide from SAP:

    Access To SLD From ABAP Fails

    http://help.sap.com/saphelp_nw04s/helpdata/en/78/20244134a56532e10000000a1550b0/content.htm

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 31, 2007 at 09:09 AM

    hi

    dont break your head for this problem.

    this is very simple to resolve.

    in SLD-> content maintenance > xi domain > check there must be five association > select integration server > then business system for logica identiy-->change the business system name .

    your problem will be resolved.

    if it not still then write to krushi.sakriya@logicacmg.com

    regards,

    KRUSHI

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 07, 2007 at 05:12 PM

    Thanks to all for your postings.

    I have finally found where the problem was. The problem was about the users and roles of PI USERS in SDL machine.

    So I have applied the note 768148 and yet works fine.

    The only comment I should do is that the message on SLDCHECK is the same, it doesn´t reflects the data configured on SLDAPICUST.

    Add comment
    10|10000 characters needed characters exceeded