Skip to Content
0

IP42 - Period not schedulled

Sep 27, 2017 at 08:21 AM

60

avatar image
Former Member

Morning.

I have created a plan in IP42 with WO to be created after 2years; 3years and 9years

Start of plan 2007, the schedule should be as follow:

1. 2yearly - 2009; 2011; 2013; 2015; 2017 .... 2025

2. 3yearly - 2010; 2013; 2016; 2019 ..... 2025

3. 9yearly - 2016; 2025

However, not all the maintenance WO are created.

1. In 2013 - only the 2yearly is created. Why not the 3yearly?

2. In 2016 - only the 9yearly is created. Why not the 3yearly?

Is there a setting to ensure all WO are created, e.g. in 2025 all 3 services should be created.

Please assist.

mwmij.png (8.6 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

8 Answers

avatar image
Former Member Sep 28, 2017 at 08:07 AM
1

Restart have the same result.

I received an answer (see below) that makes sense. It seems like it is the way of SAP to skip the call with the lowest hierarchy.

Thank you all the assistance.

"Hi,

You have the packages in Hirerarchy... like 6,7,8,9 etc

In SAP, if two packages with the same hierarchy are due at the same time, then both packages are called.

the two packages have different hierarchies, only the package with the higher hierarchy will be called.

Since the packages are 2Y - 9 and 3Y - 10, system skipped the 2Y and called the higher hierarchy.

I sugeest you to give the same Hirerarchy and create a plan in your test system, check it yourself.

Regards

Terence"


ma0af.png (16.0 kB)
Show 4 Share
10 |10000 characters needed characters left characters exceeded

Good, but did you tried it in your system to see the behaviour.

0
Former Member

I have no knowledge in building a hierarchy. Can you assist in how to do it please.

0

In your Strategy, just replace the Hierarchy with 1 for all packages, then create a plan and schedule it. For more information i advice you go through SAP help

https://help.sap.com/saphelp_erp60_sp/helpdata/en/8a/99c2537d3ab74ce10000000a174cb4/frameset.htm

Further queries on this maintenance strategy, close this message and create a new message

Regards

Terence

0
Former Member

I currently do not have access to code wpstlh1 to do look at this option. Will request access and see the outcome. Thank you.

0
avatar image
Former Member Sep 27, 2017 at 12:03 PM
0

Herewith the requested. In this case in 2017 both the 2Y and 3Y should have scheduled, however only the 3Y are.

IP11

IP10

In this case the 2Y was not scheduled in 2017, a manual call was done.


v1jvq.png (14.0 kB)
a7ezu.png (13.0 kB)
bm71u.png (20.5 kB)
uvfma.png (29.1 kB)
Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi,

You have the packages in Hirerarchy... like 6,7,8,9 etc

In SAP, if two packages with the same hierarchy are due at the same time, then both packages are called.

the two packages have different hierarchies, only the package with the higher hierarchy will be called.

Since the packages are 2Y - 9 and 3Y - 10, system skipped the 2Y and called the higher hierarchy.

I sugeest you to give the same Hirerarchy and create a plan in your test system, check it yourself.

Regards

Terence

0
avatar image
Former Member Sep 27, 2017 at 06:42 PM
0

Thank you.

1. IP10 - no change if pressing Update Scheduling

2. IP02 / 03 - plan is active and not deleted at any given time


ksurj.png (17.0 kB)
Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Sep 27, 2017 at 06:52 PM
0

When increasing the schedule dates and pressing the Update Schedule then the 2019 2Y is activated. However the 2017 2Y is still not scheduled.


hmxsi.png (13.8 kB)
Share
10 |10000 characters needed characters left characters exceeded
Peter Atkin Sep 27, 2017 at 10:06 AM
0

Julius,

Its possibly a heirarchy issue in the strategy packages.

Can you send us a screen-shot of the following:

  • Packages for the strategy (IP11)
  • Plan schedule (IP10)

PeteA

Share
10 |10000 characters needed characters left characters exceeded
Peter Atkin Sep 27, 2017 at 02:04 PM
0

Go into IP10 and press the Update Scheduling button at the bottom of the screen to see if that changes anything.

Also - check whether the plan was set inactive or deleted at any point (via IP03, then check system status log).

PeteA

Share
10 |10000 characters needed characters left characters exceeded
Peter Atkin Sep 28, 2017 at 07:35 AM
0

Try restarting the plan in IP10 to check whenter the scheduling is correct - you dont have to save it..

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Sep 29, 2017 at 09:03 AM
0

Thank you all for the assistance.

Will close the question.

Share
10 |10000 characters needed characters left characters exceeded