Skip to Content
0

SAP HANA Express Edition - XSOData: Tried to build a Fiori App in HCP Trial

Oct 14, 2016 at 09:17 AM

286

avatar image

Hello,

I've tried to make some experiences with SAP Hana Express Edition. Therefore I used Hana Express on a virtual machine (Virtual Box: host only). Within the build-in WebIDE I have created an app with a simple XSOData (with nodes.js, etc.).

If I try to access the service from my local computer, it works with no problems (I just have to enter the UAA credentials). So far, so good. Now I had the idea to connect the OData-Service with my HCP trial account in order to build a Fiori App. Unfortunately, it doesn't work... If I try to access via the HCP-destination URL, I just get a 403 error with "Invalid redirect attempt".

The destination in HCP works ("check connection"), but it takes very long to verify...

Moreover the cloud connector doesn't show any problems.

I've also found this article: https://blogs.sap.com/2015/01/12/accessing-hana-xs-odata-in-web-ide-and-beyond/, but I'm not sure if the SAML problem is the reason for this...

Can you provide me some hints, please?

Thanks and kind regards,

Stefan

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Thomas Jung
Oct 14, 2016 at 10:10 AM
0

Remember that HANA Express is running on your local machine. Likely there are firewalls and network settings that protect your local machine from being called from another server on the internet. Even if your local machine were wide open for some reason, the hostname you used in the VM isn't going to be addressable by the HCP servers. This would require setting up some sort of DNS alias in a public DNS service.

Share
10 |10000 characters needed characters left characters exceeded
Stefan Nothaft Oct 17, 2016 at 07:09 AM
0

Hi Thomas,

Thanks for your answer. Actually I've solved my problem. The problem was that I've configured the ports wrong. In fact, I had to configure the port of the node.js server, instead of the webservice...

Share
10 |10000 characters needed characters left characters exceeded