Skip to Content

Receiving XS 806 error when sending mail

I have completed SMTP configuration on my servers and am able to send email successfully to internal associates using their internet address. However, all mail going outside of the company fails with the XS 806 error

No delivery to jcargo@xxxx.net, invalid recipient address

Message no. XS806

Diagnosis

The SAP system has processed the message correctly. However, a subsequent system has classified the recipient address jcargo@xxxx.net as invalid or unknown and has not delivered the message to this recipient.

Information from External System

550 No such domain at this location

Procedure

Check the recipient address.

I am guessing there is still something not correct in my configuration but don't know where else to check. If I look at errors in SOST and run a trace, I see the message fail with the same information but I'm not sure what other settings to check. My mail host IP is correct, the address type for node setting for SMTP email configuration has an * in the Address area. What other settings can be checked? Is this settings on my SAP server or on my mail server?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Sep 22, 2017 at 07:48 PM
    My mail host IP is correct, the address type for node setting for SMTP email configuration has an * in the Address area. 

    The KBA 1955387 - Error XS806 "No delivery to ..., invalid recipient address" with long text message "501 5.5.4 Invalid Address" occurs while sending mail through SMTP

    says exact the contrary: ....This should only contain the definitve domain, which is after the "@" sign, without any astersik (*)

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 26, 2017 at 05:43 PM

    In referencing other SMTP reference tech notes, they indicate to leave the Address area with an * as I want to be able to email to anyone on the Internet. When I make the change you suggest, I can only route to internal addresses.

    If I do a route test, I have success to both internal and external email domains. However, the actual mail of the document still fails on external domains. I am currently reviewing note 455140 and 1496268 and will update with results

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 27, 2017 at 02:06 PM

    After further testing, I believe my SAP SMTP settings are correct as I have not problem successfully sending mail to internal recipients. In digging deeper, I believe the issue is our SMTP gateway so I have asked our mail admins to research and correct the problem on their end. Thanks for your suggestions on where to look.

    Add comment
    10|10000 characters needed characters exceeded