Skip to Content
avatar image
Former Member

Crystal Reports formating changes get whacked when datasource is updated

I have numerous financial reports built against a production instance financial database (SQL 2012 R2). We've recently had occasion to adjust some figures in a test instance of this same database and I want to run those Crystal Report against the test database. I go through the Set Datasource Location dialogue successfully, but when I refresh my report against the test data, ALL of my numeric fields now display with currency symbols! Where NONE of them show $$ when I run the original reports against the prod data. The SQL servers are identical (test is cloned from prod) and the test database is actually restored from a Prod backup, so the databases too are identical, as are the ODBC data sources (SQL Native Client) I'm using locally with Crystal. If I reset the Datasource back to Prod after this occurs, the Currency Symbol display persists. How do I solve this?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Sep 25, 2017 at 08:22 AM

    Hi Karl,

    1. If you expand the 'Field explorer' and enable 'Show Field Type', do those numeric fields show as 'Number' or 'Currency'?

    2. If you were to create a new formula with a static number and place it on the report, does it show a currency symbol too?

    3. What version of Crystal Reports is this?

    -Abhilash

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 25, 2017 at 02:14 PM

    Hi Karl,

    SQL 2012 requires using MS SQL Native 11 client, MS doesn't fully support the original MDAC SQL Server Native client.

    See if that resolves the issue.

    Don

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 26, 2017 at 10:55 PM

    Thank you Don and Abhilash. I'm running CR 11.0.0.1282. First thing I will try is redefining my local data sources as SQL Native 11 per Don's suggestion. If that doesn't work, I'll be back! Appreciate your help.

    Add comment
    10|10000 characters needed characters exceeded