Skip to Content
author's profile photo Former Member
Former Member

form not editable...

Hi

I've got a form that's mapped to a RCF BAPI, say Z_Create

I can't write anything in the fields...

If I map the form to another BAPI Z_Show, they are editable but they appear with the bapi's parameters by default... which I don't want.

Add a comment
10|10000 characters needed characters exceeded

Related questions

6 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Oct 25, 2007 at 10:00 AM

    Hi Philippe,

    Ur input fields will be disablaed ,when there is no element in the node (node which u binded to the form) . create an empty element in the node to make them enabled.

    for ur 2nd bapi its enabled bcos element is available in the node.

    regards

    Sumit

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 25, 2007 at 12:16 PM

    Hi Philippe,

    Make Sure when you have create the form using Apply Template => Form

    In Edit properties you have chosen <b>Input Field</b> editor for the attributes.

    A default property is TextView. If you have chosen InputField then check whether

    You have initialized the node or not.

    For 0..n node use code inside wdDoInit.

    wdContext.node<node_name>().addElement(wdContext.create<node_name>Element());

    For 0..1 node use code inside wdDoInit.

    wdContext.node<node_name>().bind(wdContext.create<node_name>Element());

    Other wise you can change the node cardinality to 1..1 or 1..n

    Regards,

    Mithu

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 25, 2007 at 09:49 AM

    Hi

    do the following in your WdDoint()

    I<YourNode>Element node=wdContext.create<YourNodeElement>

    node.setYourElement(null); // set all your values

    node.setYourElement(null);

    //finally add the element to your node

    wdContext.node<YourNode>.addElement(node);

    You can also refer :

    web-dynpro-field-elements-disabled

    Regards

    Abhijith YS

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 25, 2007 at 09:59 AM

    what does I correspond to (first line) ?

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 25, 2007 at 10:03 AM

    Hi,

    "form that's mapped to a RCF BAPI, say Z_Create"

    Does this BAPI returns any result.

    if not this is the reason why the fields are not enabled.

    To make the fields enabled

    create an element of this node .

    Regards

    Ayyapparaj

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 25, 2007 at 10:27 AM

    thanks to all of you

    I've solved the problem by creating a structure that I added to the node.

    Zqms001 myTable = new Zqms001();

    input.set<structureName>(myTable);

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.