Skip to Content
-1

Disable radiobutton in ML51 transaction

Hello all,

while using transaction ML51

i want to have only the last radio button (Plant/Activity),

and the rest should be disabled(i.e should not appear here)..

how do i achieve this, as ML51 is a parameter transaction i could not create a variant for it..

Note : My first technical question in New Platform.

thanks all.

ml51.jpg (56.8 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

8 Answers

  • Oct 14, 2016 at 05:30 PM

    Hi Vinay,

    All those values that showing in "Key Combination" Screen, is because those values are setup on "Conditions: Access Sequences (Generated Form)" Table (T682I). Depending of this key, Screen will show the values. Check image001.jpeg

    Now, if you can't do the configuration on this table, i think you can put do an Enhancement Point inside RV_GET_CONDITION_TABLES FM. Check image002.jpeg.

    image002.jpg

    Regards,

    Add comment
    10|10000 characters needed characters exceeded

    • Look at ML51 definition, ML51 is actually a parameter transaction on ML48, so either check sy-tcode EQ 'ML48' or (for parameter and variant transaction) use CL_DYNPRO=>GET_CURRENT_TRANSACTION in a local variable and check with the returned code.

      Regards,
      Raymond

  • avatar image
    Former Member
    Oct 14, 2016 at 06:19 PM

    Hi

    Probably you should change the customizing for condition type PRS in order to set a your own sequence having only the last access

    Max

    Add comment
    10|10000 characters needed characters exceeded

    • HI max,

      small correction here the transaction in ML51( in my earlier comment i have typed it as IM51, sorry for typing error)..

      Its pity that the new platform not allowing to edit the comment..

      in the top(under avatar) if i select actions->edit then its re directing me to edit the question that has started the thread.

      i think this should be look into by the concerned people.

      thanks.

      vinay.

  • avatar image
    Former Member
    Oct 24, 2016 at 10:40 AM

    2. from your screenshot go to access maintain. Check accesses assigned to access seq from 1.1

    this table determines your 'tab list' in ml51.I have these 6 options in my system. If you delete first 5 the only tab will be 'Service condition'. But BE CAREFUL deleting lines here

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member VINAY REDDY

      yes. I think on customizing level deletion is the only option

      it can influence on previously created documents using this access sequence

      to avoid it it's possible to copy and modify access sequence 0010 cond type PRS etc etc

  • avatar image
    Former Member
    Oct 24, 2016 at 03:59 PM

    Hi Vinay

    Yes you need to keep only the access you want to use in trx ML51, problably it should be better to create a new sequence and assign it to PRS

    Max

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 15, 2016 at 08:55 PM

    Hi Vinay,

    I think , you can try first using customizing! If not possible on this way, put the Enhancement Point, now, if you see the image002.jpeg attached, you will see that the tcode is ML48 and not ML51, i think this is the reason!

    Regards,

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 24, 2016 at 06:36 AM

    HI max,

    below is my screen shot,

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 24, 2016 at 07:04 AM

    HI ,

    You can use Transaction Variant to do this.

    TCODE for Transaction variant is SHD0. You can achieve your requirement using this process.

    Thanks,

    Vamsi.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 24, 2016 at 10:35 AM

    From your screenshot. 1. go to Conditions. 1.1. get access seq for PRS condit type

    2

    Add comment
    10|10000 characters needed characters exceeded