Skip to Content
0

Transport of copies: How to handle deleted objects?

Oct 13, 2016 at 07:27 AM

669

avatar image

Hi all,

Is there a way to also handle deleted (or renamed) objects within a transport of copies?

I'd like to create a transport of copies of a new version of a small tool which should replace the previous versions. The works fine for all changed and new objects, but objects which were deleted in the source system will sill be present in the target system.

Is there any way to also include deletions of objects in a transport of copies, such these get automatically deleted (if existent) when imported to the target system?

Thanks for you help,

Christian

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Matthew Billingham
Oct 13, 2016 at 07:30 AM
3

You delete an object and are prompted for a workbench request. Following through, you now have the deleted object in the request. When you import it to another system the object will be deleted. If you don't release the transport, but create a ToC from it (or manually put the deleted object entry in it), then the on importing the ToC, the object should be deleted.

Or (and it's not quite clear from your question) have you tried this and found that ToCs don't delete like workbench objects do. (I would be quite surprised).

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Many thanks for that, this was exactly what I missed, didn't think on getting the object entries from the other request.

0

Hi there,

I am facing a bigger challenge here. I did everything as described (did it many times), but getting error during the transport on the target system.

Step by step:

I had two classes I wanted to delete. I deleted them in the source system( in SE80) and saved the changes to the request. I released it, and transported to the target system. There I got syntax error for the object included in transport. Funny thing is that class did not existed on the target system anymore.

I checked the transport and only one class was marked for deletion in given request. The other one is the one where syntax error occurred during the transport itself.

I went back to source system a looked for the problematic class. It was shown in SE80 but didn't exist (could not be displayed). I tried to delete it again, but i got a short dump saying: Exception condition "CLASS_NOT_EXISTING" raised.

I created a new transport of copies (included objects from previous request) and released it. Again only one class marked for deletion. I did some research went to the E071 table and marked it there for deletion manually. Then I started the transport in target system and rc=8 again. Syntax error in class that does not even exist in target system. Please help. What can I do?

Thanks for help in advance,

Boris

0

You should post this as a separate question - you can link to this one.

0
Volker Wegert Oct 13, 2016 at 09:08 AM
1

If you have already released the workbench transport and thus removed all traces of the object, you may need to re-create the object catalog entry (and only that, not the object itself). AFAIR this can be done from the transport object list (by double-clicking)?

Share
10 |10000 characters needed characters left characters exceeded
Rob Dielemans Oct 13, 2016 at 09:52 AM
0

Hi,

If you inlude objects of a transport and some of those objects do not exist in the source system, then when releasing and then importing it in the target system it should remove those objects.

If the objects do not exist in the tranport then as Volkert said you can manually add entries in your transport top make sure that they will be deleted in the target system.

Kind regards,

Share
10 |10000 characters needed characters left characters exceeded