Skip to Content
avatar image
Former Member

PDFDocument is NULL. Exception

Hi all,

I'm a new developer in interactive forms.

When i develop a simple application and deploy it.following message is displayed:

PDFDocument is NULL. Exception com.sap.tc.webdynpro.clientserver.adobe.pdfdocument.base.core.PDFDocumentRuntimeException: Severe : PDFDocument is NULL. Exception : Service call exception; nested exception is: com.sap.engine.services.webservices.jaxrpc.exceptions.InvalidResponseCodeException: Invalid Response Code: (401) Unauthorized.

at com.sap.tc.webdynpro.clientserver.uielib.adobe.impl.InteractiveForm.afterHandleActionEvent(InteractiveForm.java:383)

at com.sap.tc.webdynpro.clientserver.cal.ClientApplication.afterApplicationModification(ClientApplication.java:1105)

at com.sap.tc.webdynpro.clientserver.cal.ClientComponent.afterApplicationModification(ClientComponent.java:887)

at com.sap.tc.webdynpro.clientserver.window.WindowPhaseModel.doRespond(WindowPhaseModel.java:570)

at com.sap.tc.webdynpro.clientserver.window.WindowPhaseModel.processRequest(WindowPhaseModel.java:153)

what i've done is:

1.download the pfx file (on SDN)and copy it to D:\usr\sap\[SID]SYS\global\AdobeDocumentServices\TrustManagerService\trust\credentials

2.install it through VA

3.change the user ADSUSER's password and check the "no password change required"

4.i check the hostname:50100/AdobeDocumentServices/Config and it has no error,but one field value is Begin traceRequired stream: "PDFDocument" not found.

so how do i resolve this problem.

Best Regards,

delma

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 24, 2007 at 12:51 PM

    Hi Delma,

    Are u getting the version info when doing the test for http: //hostname:50100/AdobeDocumentServices/Config ? If yes, then ADS is configured correctly.

    You could also check the following thread :

    pdfdocumentruntimeexception-severe-pdfdocument-is

    Hope this helps.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,Melwyn

      Thank you for your reply.

      But I tried this.it doesn't work.

      And another error is shown:

      Exception Stack Trace:

      com.adobe.ProcessingError: Credential login error while applying usage rights to PDF: C:\WINDOWS\Temp\adobewa_EPL_13579950\DM4738245631517398538.dir\DM1219701198141598399.tmp

      Specific error information:

      error while logging into credential ^0

      GeneralError: Operation failed.

      SecurityHandler.login:-1:

      The Digital ID specified is unknown.

      We just update our ep to sp10.

      Best regards

      delma

  • avatar image
    Former Member
    Oct 26, 2007 at 10:48 AM

    HI alll,

    the problem is solved by restarting J2EE ENGINE.

    But one more question is : My "submit" button cannot work.(cannot get "submit" action.

    i search the forum, it seems i should install ACF.

    but i cannot find where to download and install this.

    can anyone help me?

    thank you~!

    best regards,

    delma

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 26, 2007 at 02:12 PM

    HI

    Thank you and I received your mail and install it.But the submit button still doesn't work.

    I don't know why.

    best regrads

    delma

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Melwyn,

      Thank you for your email.but it still doesn't work.

      is it something wrong with my code?(I just follow the help and create a PDF file and save the content.)

      Or my IE's problem?

      Best regards

      delma

  • avatar image
    Former Member
    Oct 25, 2007 at 03:10 AM

    Hi,

    my NWDS is 7.0.12,but my EP is 7.0.6.

    Does this matter?Can this be the cause of the exception?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 29, 2007 at 07:48 AM

    hi all,

    the problem is solved.

    But i still don't know why.

    I just copy submittosap.xfo from design 6.0 to design 7.0 and my workspace directotry.and it works.

    I just want to know does design 7.0's submit has no effect?

    Best regards

    delma

    Add comment
    10|10000 characters needed characters exceeded