Skip to Content

Material Replication Filters & SubObjects

Hello,

I have been trying to really get a handle on material replication and am pulling the last few hairs I have left out. 😔

Two items:

1) The filters that are maintained in R3AC1, are they and(s) or or(s). We only want materials with certain material groups to come over. So, the filters are set like this...

MARA PSTAT Contains Pattern E

MAKT SPRAS Less than lower or bigger than higher bound w y

MARA MATKL Equality (= Low) A1600

MARA MATKL Equality (= Low) A2400

MARA MATKL Equality (= Low) B2000

MARA MATKL Equality (= Low) B2900

MARA MATKL Equality (= Low) B3900

MARA MATKL Equality (= Low) D1100

However, when I look in SMQ2, I see materials trying to come over that are not of these groups. So, it looks like the filters are not working. Yes, I generated the filter and did a filter sync (r/3). What gives?

2) There is a subobject field that can be maintained. I thought I could make a subobject for each material group and maintain filter accordingly. But, I cannot find documentation on the subobject ( what is it, how is it configured, etc.). I know it is a key to the filter table SMOFFILTAB. But how can I get it to work?

Thank you in advance for any assistance in this matter. Points awards accordingly.

Regards, Dean.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Oct 23, 2007 at 05:45 PM

    Hi Dean,

    First of all not sure how you can see what materials are coming in SMQ2. All you can see is the number of entries. You can only see the detail of a Bdoc in SMWP or SMW01. So not sure how you concluded that the filters dont work.

    Also, seems like your filter settings aree fine and the Bdocs should come in as expected. Can you please calrify on your SMQ2 view.

    Thanks,

    Sundeep

    Add a comment
    10|10000 characters needed characters exceeded

    • Hello,

      Problem not yet resolved completely, but found that there is a setting (in R/3) for when you have a non-unicod system (R/3) and a unicode system (SRM). In table CRMRFCPAR, there is a flag Send XML (field SEND_XML) and MUST be set to 'M' for mixed when you have unicode to non-unicode systems.

      Also, SAP says a queue is not longer used in SRM 5.0 and above but that's where we are still having problems. So I do not want to lead anyone down that path yet.

      Hope this helps.

      Regards, Dean.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.