Skip to Content
author's profile photo Former Member
Former Member

On demand syndication

Hi All,

I'm trying to run a on-demand-syndication. I made a workflow with syndication step, I created a port and also a syndication map.

Syndication via the MDSS works fine

Manual syndication works fine

Syndication via workflow, the workflow runs, the history inj the workflow says the steps were oke however no file is in the ready folder.

What do I have to do?

thanks in advance

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Oct 24, 2007 at 01:24 PM

    Hi,

    We faced a similar problem and it was due to wrong password present in the mdss.ini file, if you are using sp05 the password would be present in the encrypted format -and sometimes may not be the right one, once this was corrected in our scenario the workflow syndication step was succesfull.

    Hope this helps !

    Regards,

    Anita

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 29, 2007 at 09:54 AM

    Syndicating in a workflow, syndication on demand, extracts all records that are within the original search of the mapping.

    I prepared a syndication with a search on country and in the map properties " supress unchanged records" and ports.

    Using the Syndication server or the manual syndication it works as expected, only the changed records out of the search.

    Using the workflow with the defined port the output is different:

    All records for the port for this map are syndicated. Not just the records that are in the specific workflow and also not only those that have been changed after the last syndication as was set in the map.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 29, 2007 at 10:20 AM

    Has somebody has an answer on this "error"?

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi H.Antonise,

      You have to cascade your syndication workflow with your current workflow.

      You have to checkout your records in the start step and in the end you should cascade the checkin/out option, and launch the syndication workflow in the stop step itself. In this way you will be able to syndicate the records which you had in your workflow

      Or else you can add a task of syndicator in your workflow itself.

      Dilmit Chadha.

  • author's profile photo Former Member
    Former Member
    Posted on Oct 29, 2007 at 12:01 PM

    hi Dilmit Chadha.

    That is what I expected to happen. Syndicating only those records that are in the workflow. However the syndication step (was a workflow of one step only) took all the records that were related to the mapping used in the port.

    Did you test this way of working?

    thanks in advance

    Harrie Antonise

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 09, 2009 at 08:21 AM

    Works ok

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.