Skip to Content

Executing transaction that starts with slash (/) using command field

Sep 21, 2017 at 12:03 PM


avatar image


When I try to execute a transaction that starts a slash (/) on command field, for example “/transaction,” it give me the following error: "This function is not possible"- Message no. 00127. It seems that the system automatically interprets it as a function and do not tries, after it concludes that is not a function, that it may be a transaction code.

If I submit "/n/transaction" it is executed normally.

My question is: Does anybody know a way for me to program a workaround? I have a set of transaction codes that starts with / that I wanted to be able to execute in the command field.

Thank you in advance.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Veselina Peykova
Sep 21, 2017 at 01:13 PM

I cannot understand why /nTCODE is unacceptable in your case - I have been using transactions starting with '/' for the past 9 years and not even end users object to this /n addition (well, they use favorites for most of the long and hard to memorize codes, but still). Usually, when I explain to users that there is a system limitation and prove to them that favorites are more useful for them in many cases, they accept this.

There is a sap note which explains the reason behind this behaior: 598688 - Misleading OK code entries and mentions another option - instead of '/n' to use '=', for example, I could type =/BEV1/EMS in the command field and the transaction will be executed.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hello Veselina,

I am not saying that is not acceptable – is not a question of being acceptable or not – I just think that if it is possible to have transaction that start with a slash, then the system should not automatically discard the possibility that the user might what to submit a slash transaction code without the prefix “/n or =”.

Nonetheless, I don’t want a “fix” rather a workaround.

Thank you for your input and for the sap note, I hadn’t read/found that one.


You've got a workaround. Prefix your transaction with /n

Thread locked.