Skip to Content

WebIDE Personal Unable to Run Standard App or Extension

Sep 20, 2017 at 10:42 PM


avatar image

I am working on a requirement to extend the standard app, Display GL Account Line Items, however anytime I try to view the extensibility pane or preview the extension (or preview the app directly from webIDE personal) it returns an error.

"Failed to load UI5 component with properties '{"componentData":{"startupParameters":{}},"asyncHints":{"waitFor":[{}]},"name":"","url":"../../../../../..","async":true,"id":"application-Test-url-component"}'. - Error: failed to load 'sap/fin/central/lib/library.js' from /sap/bc/ui5_ui5/sap/fin_lib/library.js: SyntaxError: Unexpected token <"

I have tried many solutions offered from mapping the resources in the neo-app.json, and also adding to the Component file by registering the module path.

In general, anytime I try to re-start a new extension project it will not be able to load the component file from the original app, returning this error:

"Failed to load UI5 component with properties '{"componentData":{"startupParameters":{}},"asyncHints":{"waitFor":[{}]},"name":"","url":"../../../../../../webapp","async":true,"id":"application-Test-url-component"}'. - Error: failed to load 'fin/gl/lineitembrowser/display/FIN_GL_LITBEx2/Component.js' from ../../../../../../webapp/Component.js: Error: failed to load 'fin/gl/lineitembrowser/display/Component.js' from /sap/bc/ui5_ui5/sap/FIN_GL_LITB/Component.js: SyntaxError: Unexpected token <"

Any idea why it seems to get the syntax error from '<' ?

WebIDE personal can find the application and import it into my workspace, but never seem to be able to run it.

I have also tried to run the standard app from eclipse but cannot seem to get it to locate the 'sap/fin/central/lib/library.js' file. Did the same a above by trying to register module path with no luck.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Milen Dontcheff
Sep 23, 2017 at 11:27 AM

Would you please specify how you created the extension project? Which steps have you implemented?

Also please find this section in the documentation regarding the different ways of previewing an application:

Next, in the extension project, please check:

1. that its neo-app.json has a blockof sap/bc/ui5_ui5

2. that its Component.js has a reference for the original app's Component.js

Please have a look at your back-end (probably FIN_GL_LITB)

or import it in Web * and see if its Component.js file is located correctly under the root.

According to the error message you get, the extension project can't find the original app's Component.js so please do confirm it indeed exists where it should be.

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hello Milen, thank you for the response. To create I have used the wizard in web IDE personal - File > New > Extension Project (then go into the repository and select the app FIN_GL_LITB, and both imported the original app and also tried without importing)

The neo-app.json file has the block "/sap/bc/ui5_ui5" for the gateway destination entry

Web IDE personal will place the Component.js of the extension project in the webapp folder. For the original source code, there is not a webapp folder since it runs off component file.

The extension Component.js file will call the original app's component, but you are correct it cannot seem to find it for some reason.

Here is the code from the Component.js Extension -

sap.ui.component.load({ name: "", // Use the below URL to run the extended application when SAP-delivered application is deployed on SAPUI5 ABAP Repository url: "/sap/bc/ui5_ui5/sap/fin_gl_litb" // we use a URL relative to our own component // extension application is deployed with customer namespace });"", { metadata: { manifest: "json" } });


Is it possible there to be a syntax error in the manifest.json file. Would you please attach it to have a look?



here is the manifest json file

manifest.txt (831 B)
Ransome Mathias Mar 16 at 01:23 AM


I have the same issue. I imported the standard app from to my webide but I am unable to run it.

I even added a index.html file with the standard script to inject the component container into the div tag of the html. But i get errors of library files not being loaded. Please point me to a blog where there are steps to import a standard app to webide and run it.

10 |10000 characters needed characters left characters exceeded