Skip to Content

Planning Sequence When Saving, Filters and Locks

Sep 20, 2017 at 07:20 PM


avatar image

Dear Experts,

I have a problem with the default "Planning Sequence When Saving" in our IP application.

Imagine that two users are using the application at the same time, each with their selections so that no lock is overlapping. If one of them tries to save the data, the default "Planning Sequence When Saving" gets triggered.

- If the "Planning Sequence When Saving" has no filters, all the cube should be locked, so we have an error because of the lock for the second user

- if the "Planning Sequence When Saving" has filters, then we can't trigger any planning sequence via process chain as no filter is provided to it

Just keep in mind that in the we can't define any variant in the planning sequence variant of the process chain as the selection is not fixed. Also, The filter in the "Planning Sequence When Saving" is mandatory.

What did I do wrong? Any suggestion?




I can simplify the question in this way: is it possible to define the "Plannins Sequence When Saving" so that when another planning sequence runs in a process chain the whole cube doesn't get locked?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Andrey Farzatinov
Sep 21, 2017 at 08:08 AM

Hi Maurizio,

Have you tried to create special variant to call from process chain, with all the possible variable values in it(e.g. the top hierarchy node) and execute planning sequence with variant via the process chain.

Kind regards,


Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Andrey,

thanks for your reply.

The planning sequence must have two mandatory selection: Plant and Calmonth.

While the Plant is not a problem (those values never changes, so your suggestion is ok), the Calmonth changes every time.

Let me explain a little bit more in detail: the input form has two mandatory variable, 0S_PLANT and ZCALMONTH.

The Save planning sequence has the same variables, so the values are passed automatically. When the report is executed by the user, it works without overlapping locks; but when we use a planning sequence in the process chain, those variable are void and we get the errors.

What we tried is to create a non-mandatory ZPLANT variable based on exit which takes the same selection from 0S_PLANT otherwise it is blank. By doing this, we were expecting that when the user feeds 0S_PLANT, the selection is taken also into ZPLANT; when it runs from a process chain, no selection is provided so the whole cube is locked. Unfortunately it is not working.

Thanks again.


Gregor Dieckmann
Sep 22, 2017 at 11:20 AM

Hi Maurizio,

the whole basic provider is locked if the filter is empty. In the case of a 'planning function on save' you can use the option 'only read changed data': in this case the filter is merged with a run time filter that comes from the changed data in the buffer. The run time filter is the projection of all block characteristics (used in the respective planning function) from the changed records.

Simple example:

Filter: Characteristic A = a1

Function: Block characteristics (i.e. field not to be changed): B, C

Changed data records:

A   B   C   ...
a1  b1  c1  ...
a1  b1  c2  ...

Run time filter (projection from changed data to block characteristics):

Characteristic B = b1

Characteristic B = c1, c2

So the merged filter is

Characteristic A = a1

Characteristic B = b1

Characteristic B = c1, c2



10 |10000 characters needed characters left characters exceeded