Skip to Content
author's profile photo Former Member
Former Member

set language of webshop in XCM

Hi all,

I'm new in doing configurations in XCM for a B2B web shop. Does anybody know how to change the language of the web shop into Dutch. I tried to change the language of the JCO to NL. And after restarting the application, I didn't see that it changed.

Do have to configure the language in the xml-files?

Kind regards,

Timo

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Oct 22, 2007 at 02:14 PM

    Hello Timo,

    For web applications SAP mostly takes the language of the user's browser.

    If you're using Internet Explorer go to Tools->Internet Options->Languages. Place Dutch as the upper most language.

    The webshop will appear in Dutch...

    I think there is also the url parameter sap-langu (not sure if the parameter name is correct though) but I'm not sure if this one overrides the IE language setting.

    Reward points if useful,

    Kind regards,

    Joost

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 29, 2007 at 10:13 AM

    THANKS FOR YOUR HELP!!!

    Greetz,

    Timo

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 29, 2007 at 10:17 AM

    Hi,

    Or else Please add the attribute "&sap-language= "with the language that you want to see.

    Thanks and regards,

    Santosh P

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 29, 2007 at 11:14 AM

    Hi all,

    It doesn't work yet.

    I've tried to add the parameter "?language=nl" to the link. It only changed the language of the logon screen. When I login, the value has been put back to english.

    I've also tried to create a different ui-component with property language set on nl. But that doesn't work either.

    I don't know what do anymore.

    But thanks for your help anyway!!!

    Greetz

    Timo

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 20, 2007 at 09:54 AM

    Hi,

    Set the language in XCM in UI configuration. this is used to set default language and backend communication.

    It is located at XCM>Components>Customer>UI>custom UI(your UI)

    Regards,

    Sateesh Chandra

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.