Skip to Content
0
Former Member
Oct 19, 2007 at 12:48 PM

Db13 message error DB

326 Views

Hello everybody.

After that i have installed a new system (SOLMAN 4 R2 on Maxdb)on a server where there´s already a system, i call DB13 and i receive always a dialog box error (when refreshing too):

DBMRFC Function : DBM_GETF

Command : DBAHIST DATE=20061018

Error : DBM Error

Return Code : -2

Error Message : ERR_SYSLOGON: Logon to operating system

Message no. SADA001

If i go to DB59 and test the connection to my Maxdb, i receive this log:

1. Connect. test with "dbmcli db_state" Unsuccessful

dbmcli_command_execute_error

Enter server name: Enter database name: Error! Connection failed to node (local) for database (no dbname):

-24965,ERR_SYSLOGON: Logon to operating system failed

-24994,ERR_RTE: Runtime environment error

1,Logon failure: unknown user name or bad password.#

(OS error code 1326)

External program terminated with exit code 2

2. Connect. test with command mode "dbmrfc db_state" Unsuccessful

dbm_system_error

DBMRFC Function : DBM_EXECUTE

Command : db_state

Error : DBM Error

Return Code : -2

Error Message : ERR_SYSLOGON: Logon to operating system

3. Connect. test with session mode "dbmrfc db_state" Unsuccessful

dbm_system_error

DBMRFC Function : DBM_CONNECT

Error : DBM Error

Return Code : -2

Error Message : ERR_SYSLOGON: Logon to operating system

4. Connect. test with "native SQL" ( HE2 ) Unsuccessful

For detailed information, see the developer trace for work process: 0

My sap and my Maxdb are working without problems, i can make all the functions in DB13 (backups, checks, ...), but i´d like to know why i find always this problem.

Is this a problem of DBM user?Or Users/Envirnonment Variabels?

During installation of SOLMAN i have only 1 password valid for all users (DB and OS users). If i connect direct in dialog mode to Server with Os server and then to DB (with DB user), i don´t have any problems.

Is a problem in SM49? Or a problem in parameter in dmcli?

All the 4 connect test in DB59 fail:

- Connect. test with "dbmcli db_state"

- Connect. test with command mode "dbmrfc db_state"

- Connect. test with session mode "dbmrfc db_state"

- Connect. test with "native SQL"

as above in log.

Can anyone me help?What can i check?

Thank you in advance.

Alberto