Skip to Content
author's profile photo Former Member
Former Member

Default customer in sales order

Dear friends

In my sales order, in customer number field customer number say 400000XX coming default. I want that field blank while creating new sales order.

how i do this. Please help

Regards

Inder

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Oct 18, 2007 at 06:16 AM

    Hi Inder,

    Go to transaction CMOD.

    Enter project name and select the button Create

    we want to create a project to enahance trasnaction VA01 .

    - Create a project called ZVA01

    - Choose the Enhancement assign radio button and press the Change button

    In the first column enter V45A0002 Predefine sold-to party in sales document.

    Note that an enhancement can only be used in 1 project. If the enhancement is already in use, and error message will be displayed

    Press Save Press Components. You can now see that enhancement uses user exit EXIT_SAPMV45A_002. Double click on the exit.

    Now the function module is displayed. Double click on include ZXVVAU04 in the function module

    Insert the following code into the include: E_KUNNR = '400000XX'.

    Activate the include program. Go back to CMOD and activate the project.

    Goto transaction VA01 and craete a salesorder.

    Note that Sold-to-party now automatically is "400000XX"

    Reward points pls.

    Regards,

    Govind.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 18, 2007 at 06:03 AM

    hi

    because of an user exit the default number is coming

    check out if any user exits are there and also check for screen variants

    regards

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 18, 2007 at 06:04 AM

    Hi

    thats bcoz of userexit. your system has the userexit V45A0002 default sold to party.

    Deactivate the userexit V45A0002.

    Ask your ABABer to help you out to Deactivate the Userexit

    Reward if helpfull

    Muthupandiyan

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 18, 2007 at 06:09 AM

    Inder,

    1)Check from ur ABAPer whether you have used user exit MV45AA user exit..

    2)In customer master of this default SP deactivate default tick..

    REWARD IF this helps...

    Regds

    MM

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.