Skip to Content
avatar image
Former Member

Mail QUEUE is full. Sost taking soo long! Urgent Please!

Hi,

My mail QUEUE is full because there is no job scheduled to send the emails. when I go to tcode sost, it is taking forever. Is there any other way to clear the queue? I just want to delete them since there are too many (257)...

It is urgent please...

Thanks,

I will post points for sure

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

9 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 17, 2007 at 06:25 PM

    Hi,

    Yes technically it is nothing 267.. but in QA system, nobody scheduled a job before... it is been like that for almost 4 months. now they realized... in this case, I am trying to delete everything in waiting=267 so i can start from clean. If i schedule a job, those all email will sent, but we dont need that.

    Thanks, let me if you think of anything else, or i'll will change the parameter.

    Thanks,

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Afi,

      Did you try the date selection option or is SOST dumping in the beginning?

      Also can you post the ABAP dump here.

      Regards.

      Ruchit.

  • avatar image
    Former Member
    Oct 17, 2007 at 05:21 PM

    Hello Afi,

    In case you want to delete select all the mails and press the delete icon. What is the issue with that.

    Regards.

    Ruchit.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 17, 2007 at 05:29 PM

    Hi,

    Thanks for replying.. the issue is when I go to SCOT, there 269 waiting in queue. if i try to go to Sost, it takes forever and timed me out. since the queue has so many emails sitting, I cant delete them using TCODE sost.. Please help!!!

    Thanks,

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Afi,

      Try this. In SOST you can select data my date stamp. Instead of selecting all dates reduce this parameter and then try to delete them in smaller blocks. Also 267 is not that much, In my SOST I can see several hundred mails at a time. Any reduce you selection of the basis of date.

      Regards.

      Ruchit.

  • avatar image
    Former Member
    Oct 17, 2007 at 05:37 PM

    Hi,

    Yes, it make sense. Thanks a lot. I will get back to you ASAP I am done with that.

    Thanks a lot agian,

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 17, 2007 at 06:49 PM

    Hi,

    yes i tried, it still timed out. we are not allowed to hold dialog proce... more than 300 sec... if I change that parameter, Do i need to reboot the sap? it says its is DynamicallySwitchable, but we are on 620. soembody told me if we are on 620, we have to reboot our systems. is it true?

    Thanks,

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Afi,

      300 is too less. Make it 600s at least. Normally existing values should be doubled. Dont go for a 10 fold increase. Also 3000 secs is too large.For dynamically switchable parameters restart is not needed. I don't think this should be different for 620 also. Anyways try it first.

      Regards.

      Ruchit.

  • avatar image
    Former Member
    Oct 17, 2007 at 06:55 PM

    Hi,

    Also, what is the maximum sec can I put in that parameter? I will be increasing to 3000 sec from 300sec.. what if i need more time? Can I add more? any limist? also once i change that, do I need to restart sap system? it is dynamically switchable. somebody told me if we are running 620, it requres reboot for dynamically switchable too..

    Thanks,

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 17, 2007 at 07:01 PM

    HI,

    Are you sure I should not go for 10 fold increase coz they want me to finish work as soon as posible..

    Thanks,

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Afi,

      600s is default value of the parameter and normally should not be changed. I don't know why in you case it is 300s. Check OSS notes 25528.

      Regards.

      Ruchit.

  • avatar image
    Former Member
    Oct 17, 2007 at 07:47 PM

    Hi,

    Sorry my fault, I was looking at minimum 300 sec and default is 600. I have changed to 3000 sec, it is running, its been over 30 min and running, why is it taking that long? any idea?

    Thanks,

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Afi,

      What is running ? The deletion of mails ? Can you post that ABAP dumps you received earlier. I am not sure if it was run time error only.

      Regards.

      Ruchit.

  • avatar image
    Former Member
    Oct 17, 2007 at 08:22 PM

    Hi,

    It is working good now. It took about 700 sec next time. there were still some queue were there. now it is working fine. but still when i go to sost, it takes about 34 sec. is it normal?

    Thanks,

    Add comment
    10|10000 characters needed characters exceeded