Skip to Content
0

SAP EP: Fiori Framework Page can't display more than 30 Tiles?

Sep 20, 2017 at 04:37 PM

56

avatar image

Dear Fiori-Wizards,

System Info:

SAP EP on NW AS JAVA 7.5 SPS 8 (UI5 Libraries switched to 1.44.X). Using the the AS JAVA's Libraries as recommended in the latest SAP-Notes.

Background:

I'm currently building a Prototype for a Hybrid-Portal with Fiori 2.0 UX. I.e. Fiori Framework Page with Fiori Desktop and Belize Themes, 1 UI5-Apps and about 3 dozens of WDA Apps consumed via Remote Catalogues.

Problem / Phenomenon:

Whenever the Fiori Framework page has more than 30 Tiles (not catalogues) to display, the initial rendering crashes with a javascript error. The error is also (thankfully) thrown in the portal logs, so I assume there is a bug in the UI5-Libraries. It looks like this (trying to avoid screenshot for sake of SEO... let's hope it's still readable):

IE11 Console:

URL    Protokoll    Methode    Ergebnis    Typ    Empfangen    Benötigte Zeit    Initiator    Warten‎‎    Start‎‎    Anforderung‎‎    Antwort‎‎    Cachelesezugriff‎‎    Zeitspanne‎‎/sapui5-1.44/resources/~201707050905~/sap/ushell_abap/library-preload.json    HTTPS    GET    404    text/html    2,28 KB    15 ms    XMLHttpRequest    1903    0    15    0    0    1560

Portal Dev Log:

Sep 20, 2017 6:30:06 PM com.sap.ui5.resource.ResourceServlet serveResource
WARNING: [404] "/resources/sap/ushell_abap/library-preload.json": Service=25ms, Find=25ms
Reason: Resource could not be found!
Severity Single Click Filter by Severity Negative Single Click Filter by Severity ErrorDate Single Click Filter by Date Negative Single Click Filter by Date 2017-09-20Time Single Click Filter by Time Negative Single Click Filter by Time 18:30:06:260Category Single Click Filter by Category Negative Single Click Filter by Category System.errLocation Single Click Filter by Location Negative Single Click Filter by Location System.errApplication Single Click Filter by Application Negative Single Click Filter by Application sap.com/ui~five

This problem does NOT occur when launching the content from the Gateway's FLP, i.e. the problem must reside within the portal.

.

We're going to patch to SPS9 ASAP and maybe this "feature" will be gone by then.. but I'm still curious: Has anybody else encountered something alike yet?

Cheers, Lukas

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers