Skip to Content
0

Survey added in Visit is in Display mode

Sep 20, 2017 at 09:56 AM

179

avatar image

Dear C4C Experts,

I have configured Visits in our tenant and I have created the Activity Planner and assigned the mandatory tasks and surveys in the activity planner. I have created the rules also so that these tasks are assigned to the visits.

There are two issues that I am facing

1. Even though the "Assign Automatically" flag is enabled in the activity planner, the tasks and surveys are not assigned in the Visits automatically. Only after clicking in ADD button these relevant tasks are listed.

2. I manually added the survey to the Visit and when I open the survey it is opening in DISPLAY mode and I am not able to fill in the survey responses.

Could you please let me know what am I missing in this scenario.

Thanks in advance,

Siraj

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Prasanth Sarma Aryasomayajula
Sep 20, 2017 at 10:47 AM
0

You can answer the Survey questions by following the below steps.

  1. Go to Visits Work center
  2. Select the Visits View.
  3. Open any Visit
  4. Go to the Survey Tab
  5. Select the Survey Line.
  6. Click on Actions Button and choose Edit for the Survey questions to open in a new page to answer.
Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Prasanth,

Thanks for your quick response. I could edit the survey as per your steps.

Regards,

Siraj

0
Siraj Saibudeen Sep 20, 2017 at 10:24 AM
0

Hi Everyone,

The first issue is solved by adding a workflow rule for the Visit BO. The workflow rule Action --> Refresh Visit helped in assigning the tasks and surveys automatically to the visits.

But still the surveys are in Display mode :(

Regards,

Siraj

Share
10 |10000 characters needed characters left characters exceeded
Grayson Gates
Sep 20, 2017 at 02:30 PM
0

Hi Siraj,

To complement Prasanth's answer, you can also go to your fine tuning settings in Business Configuration for the object "Visits" and set a time frame of when Activity Plans should be added to Visits on a day interval automatically by the system. IN this configuration you for example set 5 days, and during a background job, the system will apply Activity Plans to visits 5 days within todays window automatically. But the workflow does help you now.

For option 2, if you are using HTML5 view of Hybris Cloud for Customer, then follow the exact steps Pransanth mention to open edit mode. If using the Fiori, you shouldn't be running into this problem unless the visit is completed.

Please advise of screen you are using and if following Prasanth's steps in HTML is not working. Also please check status that it is not "completed"

Screenshots will help

Regards,

Grayson

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Grayson,

Both the issues are sorted now, and thanks for the note related to setting the time frame in Visit configuration activity.

I tried editing the survey in HTML5 mode just by clicking the survey link. But it did not work since the same behavior worked in Fiori client. Hence I got confused with the system behavior, but it seems we do have two different approach to filling the surveys in HTML5 and Fiori clients.

Now I am all set with working on Visits and Activity Plans. Thanks for your support.

Regards,

Siraj

0