Skip to Content
0

Fixed Hierarchy node not getting updated

Sep 18, 2017 at 05:58 PM

32

avatar image

Hi,

May be I am missing something ...

I have configured package link exactly to Export the file and then import with Parenth1 = Fixed member

While exporting itself i have specified PARENTH1=*STR(FIXED_MEMBER) and i can actually see the file exported has all the parenth1 populated with Fixed_Member

However when i re import the same file I see Parenth1 column still empty.

I have tried csv and txt formats, Package link status shows success, tried running individual packages too they showed success but not updated the dimension. Pretty straight forward but still something missing.

My export transformation file:

Import Transformation file:

End result in Dimension:

I have tried exporting the file in .csv and .txt formats, both formats did not succeed.

scn1.png (6.4 kB)
scn2.png (8.6 kB)
scn3.png (6.5 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Vadim Kalinin Sep 18, 2017 at 06:23 PM
0

It's not necessary to export PARENTH1

Export ID only and on import use:

ID=ID

PARENTH1=*IF(ID=*STR(TOTAL_BRAND) THEN *STR(); *STR(TOTAL_BRAND))

It will work!

Show 2 Share
10 |10000 characters needed characters left characters exceeded

This is sad!!

adjusted transformation file as advised, I see all the logs successful but at the end nothing happens.

Plain and pretty straight forward...why is it not updating :-(

My export file preview:

and the transformation file has the mapping as below:

did it work for you?

scn4.png (4.8 kB)
scn5.png (7.9 kB)
0

First - why I see PARENTH1 column in export file??? You need only ID!

Export mapping:

ID=ID

Import mapping:

ID=ID

PARENTH1=*IF(ID=*STR(TOTAL_BRAND) THEN *STR(); *STR(TOTAL_BRAND))

Also LANGU is not needed!

0
Ellora Dobbala Sep 20, 2017 at 04:14 PM
0

I will share my coordinates please drop a missile on my head ;-)

I was referring to this chain /CPMB/IMPORT_DESCRIPT instead of /CPMB/IMPORT_MASTER

I fixed it and works fine now

Thank you

Show 1 Share
10 |10000 characters needed characters left characters exceeded

:) :) :)

Have a nice day!

0