Skip to Content
0

SUM Path Issue

Sep 18, 2017 at 07:37 PM

272

avatar image

I am in the process of upgrading my Solution Manager from 7.1 to 7.2. Using the latest SUM tool 1.0 SP21, right off the start I get an error that it cannot find files during the kernel check, See below, I am using SIDADM. I can from windows server, open a command prompt and type in disp+work -v and get results, so my path works. I can cleaned the path, tested the path, just seems like SUM is only grabbing the SYSTEM path and not USER path. So I tried that, added my path to the kernel in the system path. No way! I did find a few oss notes that quote the same error, but no help. Any advice out there?

1 ETQ201 Entering upgrade-phase "MOD_SELROADMAP/TOOLVERSXML_KERNELPARAMS_ROADMAP" ("20170918130836")

4WETQ399 Cannot find 'tp' in current path!

4WETQ399 Cannot find 'R3trans' in current path!

4WETQ399 Cannot find 'R3load' in current path!

2 ETQ367 Connect variables are set for standard instance access

4 ETQ399 System-nr = '', GwService = 'sapgw' Client = '000'

1 ETQ200 Executing actual phase 'MOD_SELROADMAP/TOOLVERSXML_KERNELPARAMS_ROADMAP'.

1 ETQ399 Phase arguments:

2 ETQ399 Arg[ToolVersXML] = 'ToolVers.xml'

2 ETQ399 Arg[TypesList]= 'CUR'

2 ETQ399 Arg[ToolFilter]= 'disp+work'

2 ETQ399 Arg[Options]= 'SETKERNELPARAMS'

1 ETQ399 Using a tool filter disp+work...

1 ETQ399 Determining some tool versions from current path...

1 ETQ399 Executing the command 'disp+work' for the 'non-ignorable' tool 'disp+work' in cur-path '(null)'

1 ETQ399 Output of 'disp+work' to be found in 'disp+work_cur.out'

1EETQ399 Error: Non-ignorable executable 'disp+work' in dir '<current tool path>' does not exist - missing!

1EETQ399 Last error code set is: Error: The command 'disp+work' from tool 'disp+work' could not be executed

1EETQ399Xsuccessfully

1EETQ204 Upgrade phase "TOOLVERSXML_KERNELPARAMS_ROADMAP" aborted with severe errors ("20170918130836")


10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Yogesh Patel
Dec 16, 2017 at 05:29 AM
0

Hello Joshua Lacroix,

Please look in to SAP Note :

2231295 - SUM error: Cannot find executable 'disp+work' in path: PATH

Thank you

Yogesh

Share
10 |10000 characters needed characters left characters exceeded
Joshua Lacroix Dec 20, 2017 at 06:42 PM
0

I should now detail my findings on this issue.

What I found was, the SUM tool must have a character length limit it can read from the system path.

According to this link

https://software.intel.com/en-us/articles/limitation-to-the-length-of-the-system-path-variable

it describes the system path length for windows 2008 server.

My system was well below the character threshold, if I opened a CMD, launched set or path, I could see my complete path along with the path to my kernel. I was under the limitation set by windows. I know this because I could execute kernel commands from my CMD path.

However, when SUM would launch and read my path, it appears it couldn't read as many characters. I had 2 options, clean my path down in order for SUM to make it to my kernel path or move my kernel path string to the start of the system path. I strongly believe its an issue with the SUM tool, I cant remember my log of the error and how many characters SUM would read, but I know it wasn't very long. I have reproduced it now several times on other servers, and now my fix is to add my kernel lines to the start of the system path.

Share
10 |10000 characters needed characters left characters exceeded