Skip to Content

Picture not showing when report run

Sep 18, 2017 at 01:38 PM


avatar image


Just updated to SP21 and VS 2017

Added a picture to a report that is shown in the crystal report viewer on a windows form. When adding the picture every thing is shown but when saved and run it doesn't show the picture and when I go and edit the report I don't see the picture ether.

If I run / edit an existing report with a picture I can see it.

Any Ideas?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Tony Evans Nov 29, 2017 at 01:48 PM

Hi Dan

Sorry meant to reply earlier.

Looks like the problem is to do with the jpg's original canvas size. Rather than resizing in the report used PaintShop to reduced the canvas size and then added that to the report and now it is shown.

10 |10000 characters needed characters left characters exceeded
Don Williams
Sep 19, 2017 at 05:51 PM

Depends on how you are saving it. The ReportDocument does not have the ability to add a picture so you need to save the ReportClientDocument object.


Show 4 Share
10 |10000 characters needed characters left characters exceeded

Hi Don

Thank you for your response, not quite sure what you mean. I add a new item, select Crystal Report and select As a Blank Report, I then right click in the report select Insert, Picture, Choose the picture to insert, Open and there is the picture I want on the report. When I Save and then run the report I don't get the picture and when I reopen it the picture is no longer shown. This only happens on new reports that I have create with VS2017 and SP21, If i run (or open) any of the previously created reports in VS2017 with pictures on everything is fine.

Any Ideas Please?



Hi Tony,

Thanks for the steps. I just tried it and I don't see the issue.

Try right clicking on devenv.exe and selecting Run As Administrator and test again. It may be a permission issue.

Is the picture a JPG or ????.

Is it loading the image locally or from a Server Share?

Are you saving the report in your app folder, default?



Hi Don

Tried running as administrator but had the same problem, the image is a JPG and it is currently in the source directory with all the other programs.

I will try to repair VS2017 to see if this makes a difference and let you know


Check you AV log also, could be your anti-virus software is blocking it. I've seen that before...