Skip to Content
author's profile photo Former Member
Former Member

Problem with Special Characters

Hi,

I am facing a problem is with all special characters. As XI does not accept special characters , I am not able to understand , how to pass these special characters. Actually , I am working on a Idoc to http Scenario. Here the Idoc values are passing some special characters like "Muller & Co". When these values are being converted into xml .. the output cXML is showing the value as "Muller &amp CO". So What should I do in order to get my output xml value as Muller & CO. Not only for this .. I need a solution for all special characters. Can some one help me in this pls.

Thanks in Advance ,

Hemanthika

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Posted on Oct 13, 2007 at 10:45 AM

    Hi ,

    Please refer the following threads

    converting-special-characters

    handling-special-characters-in-an-idoc-to-xml-inte

    restricting-special-characters-in-xml-within-xi

    Check this also

    handling-special-characters-in-an-idoc-to-xml-inte

    Regards.,

    V.Rangarajan

    Message was edited by:

    ranga rajan

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Hemanthika ,

      Having a look to the help.sap.com page, i could find the next:

      Processing Business Data Using the Plain HTTP Adapter

      http://help.sap.com/saphelp_nw04/helpdata/en/43/64db4daf9f30b4e10000000a11466f/frameset.htm

      <i>he payload must be sent as an XML document with code page UTF-8, so that all services of the Exchange Infrastructure can process the document.</i>

      and

      Processing Business Data Using the Plain HTTP Adapter

      http://help.sap.com/saphelp_nw04/helpdata/en/43/64db4daf9f30b4e10000000a11466f/frameset.htm

      <i>The payload in the HTTP body is appended to the message as a binary document. The payload must be sent as an XML document with code page UTF-8, so that all services of the Exchange Infrastructure can process the document.

      If the specified code page for the HTTP body does not correspond to the default setting UTF 8, the system converts the HTTP body to the corresponding code page; in the XML document, the system replaces the tag encoding=UTF-8 with the corresponding code page tag.</i>

      Maybe the clue is in this last sentence, you must replace ( by mapping ) the encoding to UTF-8.

      Nevertheless, ask your system administrator about the encoding just to make sure the used encoding is not UTF-8.

      Hope this helps.

      Eduardo.

  • author's profile photo Former Member
    Former Member
    Posted on Oct 13, 2007 at 01:38 PM

    hi,

    Option 1) Try accesing it with xpath and escaping the special characters.

    Option 2) Read your generated xml file and write a parser to parse it right and create a new one...with custom code(this might be easier)...

    Regards

    Ravi Raman

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Mar 31 at 02:44 AM

    Try using Java Mapping to remove those special characters

    Use below link

    Remove non UTf-8 charcatersa

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.