Skip to Content
0

FF67 / FF_5 Business Area Mandatory Posting Error

Sep 15, 2017 at 04:58 PM

146

avatar image

Hello dear experts,

Please kindly give me advice about this situation. I'm uploading bank statements using transactions FF67 (manual) and FF_5 (electronic). There is one case at posting time. For some postings that involve a vendor line item system shows an error because "business area" is a mandatory field. There is a substitution assigned as constant value for business area, but it only works when business area has value, if it is blank then substitution is not getting fired.

I have checked BTE 1120 but i'm not sure if it will work for business area, the field is not available in structure BSEGSUB.

If i create a substitution as user exit, will it work?. I can't set business area as an optional field, it has to be mandatory.

Thank you.

Best regards,

Fernando

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Sanil Bhandari Sep 16, 2017 at 12:47 AM
0

Hi

In you development post transactions without business area and check the field BKPF-TCODE, which is populated when the accounting document is created. Now check if you have GSBER as a field allowed for substitution in Maintainance view for table GB01 for BSEG, for set class 9. If no, allow the same.

Next write a substitution rule as:

SYST-TCODE IS ZTCODE and BUKRS=XXXX

GSBER=1234

Include the BKPF-TCODE in the set ZTCODE.

It should work. The substitution has to be written for line item level. You may include additional parameters like Account type etc in prerequisite depending on your business requirements

Regards

Sanil Bhandari

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hi Sanil,

Thanks for your answer. I have tried that on my development system but it didn't work. I added a new step with "TRUE" as prerequisite for testing purposes and assigned a constant value for business area. When i tried to do the posting as visible through FEBAN,. "business area" field as mandatory doesn't get any value until i put in it a value manually. After that subtitution just get fired and the manual value is changed by the defined in substitution step.

Here are a few screenshots.

Substitution Step

Posting Visible - FEBAN

Value Assigned Manually and Value Changed After Substitution

Regards,

Fernando

substitution.png (48.0 kB)
posting.png (11.9 kB)
posting2.png (19.6 kB)
0

Hi

I had mentioned the prerequisite as below:

Company code = 1234 and T Code =XXXX

Where T Code should be the one which is applicable for successfully posted FEBAN Document.Could you try with those?

Regards

Sanil

0

Hi,

i tried that option too. I get the same result as using TRUE as prerequisite.

0
Bastiaan Jansen Sep 18, 2017 at 02:32 PM
0

Another solution could be defining a generic search string which allways populates business area with a constant value

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Thank you Bastiann for your answer. I've never used search string. Business area value will depend on company code. Is it possible to add logic to search strings for assigning different business areas according to company codes?.

Regards,

Fernando

0

Yes, make a searchstring which always matches (for example "?) and link it on the second page to a companycode specific bankaccount filling the business area

0
Gustavo Vazquez Sep 18, 2017 at 03:38 PM
0

User exit EXIT_SAPMF40K_001

:-s

Show 1 Share
10 |10000 characters needed characters left characters exceeded

I checked that too. I doesn't work for my case. FEBEP-GSBER is populated but when posting BSEG-GSBER is not populated.

0