Skip to Content
author's profile photo
Former Member

4.6c Installation Problem

Hi All,

I'm trying to install 4.6c on two new Server. Both installation failed at 91%.

Config:

Two different Server (Dell and VMware Virtual Maschine)

Windows Server 2003 R2 (one Enterprise, one Standard)

Oracle 9.2.0.8 with the latest patch set.

Central&Database instance

local installation

R3setup failed at 91%, Error SAPUSERPASSWD_NT_ORA ExecuteCheck

Exit Code from ..\sapdba: 2.

I'm sure that i typed the right password at this time. With sqlplus i can normaly connect to the database with sapdba, sys and system(with the right password).

The error is reproducible, i have try'd to install all new (OS, DB, SAP).

Please Help, time is running out

Thanks a lot

Chris

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • author's profile photo
    Former Member
    Oct 11, 2007 at 05:40 PM

    Hi All,

    I have put the last lines of my CENTRDB.log and the dev_w1.log. May be it helps...

    -


    INFO 2007-10-11 16:14:46

    Switching to Archive Log Mode

    INFO 2007-10-11 16:14:46

    Setting Password for the Database User

    INFO 2007-10-11 16:14:48 SAPUSERPASSWD_NT_ORA SyCoprocessCreate:931

    Creating coprocess I:\usr\sap\C46\sys\exe\run\sapdba ...

    INFO 2007-10-11 16:14:52 SAPUSERPASSWD_NT_ORA ExecuteDo:0

    RC code form SyCoprocessWait = 2 .

    ERROR 2007-10-11 16:14:52 SAPUSERPASSWD_NT_ORA ExecuteCheck:0

    Exit code from I:\usr\sap\C46\sys\exe\run\sapdba: 2.

    ERROR 2007-10-11 16:14:52 SAPUSERPASSWD_NT_ORA InternalInstallationDo:0

    Phase failed.

    INFO 2007-10-11 16:14:54 SAPUSERPASSWD_NT_ORA SyCoprocessCreate:931

    Creating coprocess I:\usr\sap\C46\sys\exe\run\sapdba ...

    INFO 2007-10-11 16:14:57 SAPUSERPASSWD_NT_ORA ExecuteDo:0

    RC code form SyCoprocessWait = 2 .

    ERROR 2007-10-11 16:14:57 SAPUSERPASSWD_NT_ORA ExecuteCheck:0

    Exit code from I:\usr\sap\C46\sys\exe\run\sapdba: 2.

    ERROR 2007-10-11 16:14:57 SAPUSERPASSWD_NT_ORA InternalInstallationDo:0

    Phase failed.

    ERROR 2007-10-11 16:14:57 SAPUSERPASSWD_NT_ORA InstallationDo:0

    Phase failed.

    ERROR 2007-10-11 16:14:57 InstController Action:0

    Step SAPUSERPASSWD_NT_ORA could not be performed.

    ERROR 2007-10-11 16:14:58 Main 🤯

    Installation failed.

    ERROR 2007-10-11 16:14:58 Main 🤯

    Installation aborted.

    -


    -


    trc file: "dev_w1", trc level: 1, release: "46D"

    -


    *

    • ACTIVE TRACE LEVEL 1

    • ACTIVE TRACE COMPONENTS all, M

    *

    B

    B Thu Oct 11 16:13:18 2007

    B create_con (con_name=R/3)

    B Loading DB library 'I:\usr\sap\C46\SYS\exe\run\dboraslib.dll' ...

    B

    B Thu Oct 11 16:13:21 2007

    B Library 'I:\usr\sap\C46\SYS\exe\run\dboraslib.dll' loaded

    B Version of library 'I:\usr\sap\C46\SYS\exe\run\dboraslib.dll' is "46D.00", patchlevel (0.1663)

    B New connection 0 created

    M relno 4640

    M patchlevel 0

    M patchno 1674

    M intno 0

    M pid 1324

    M

    M ***LOG Q0Q=> tskh_init, WPStart (Workproc 1 1324) [dpxxdisp.c 958]

    I MtxInit: -2 0 0

    X EmInit: MmSetImplementation( 2 ).

    X <ES> client 1 initializing ....

    X Using implementation std

    M <ES> Memory Reset enabled

    X ES initialized.

    M ThSysUsrCheck: clear T1

    M calling db_connect ...

    C Got ORACLE_HOME=H:\oracle\C46\920 from environment

    C Got NLS_LANG=AMERICAN_AMERICA.WE8DEC from environment

    C Logon as OPS$-user to get SAPR3's password

    C Connecting as /@C46 on connection 0 ...

    C

    C Thu Oct 11 16:13:22 2007

    C *** ERROR => OCI-call 'olog' failed: rc = 1017

    [dboci.c 2435]

    C *** ERROR => CONNECT failed with sql error '1017'

    [dboci.c 7003]

    C Try to connect with default password

    C Connecting as SAPR3/<pwd>@C46 on connection 0 ...

    C *** ERROR => OCI-call 'olog' failed: rc = 1017

    [dboci.c 2435]

    C *** ERROR => CONNECT failed with sql error '1017'

    [dboci.c 7003]

    C Got NLS_LANG=AMERICAN_AMERICA.WE8DEC from environment

    C Logon as OPS$-user to get SAPR3's password

    C Connecting as /@C46 on connection 0 ...

    C

    C Thu Oct 11 16:13:23 2007

    C *** ERROR => OCI-call 'olog' failed: rc = 1017

    [dboci.c 2435]

    C *** ERROR => CONNECT failed with sql error '1017'

    [dboci.c 7003]

    C Try to connect with default password

    C Connecting as SAPR3/<pwd>@C46 on connection 0 ...

    C

    C Thu Oct 11 16:13:24 2007

    C *** ERROR => OCI-call 'olog' failed: rc = 1017

    [dboci.c 2435]

    C *** ERROR => CONNECT failed with sql error '1017'

    [dboci.c 7003]

    B ***LOG BY2=> sql error 1017 performing CON [dbsh 0707 ]

    B ***LOG BY0=> [dbsh 0707 ]

    B ***LOG BY2=> sql error 1017 performing CON [dblink 0627 ]

    B ***LOG BY0=> [dblink 0627 ]

    M ***LOG R19=> tskh_init, db_connect ( DB-Connect 000256) [thxxhead.c 1124]

    M in_ThErrHandle: 1

    M *** ERROR => tskh_init: db_connect (step 1, th_errno 13, action 3) [thxxhead.c 8076]

    M

    M Info for wp 1

    M

    M stat = 4

    M reqtype = 1

    M act_reqtype = -1

    M tid = -1

    M mode = 255

    M len = -1

    M rq_id = -1

    M rq_source = 255

    M last_tid = 0

    M last_mode = 0

    M int_checked_resource = 0

    M ext_checked_resource = 0

    M report = > <

    M action = 0

    M tab_name = > <

    M

    M *****************************************************************************

    M *

    M * LOCATION SAP-Server WSWSAPC46_C46_00 on host WSWSAPC46 (wp 1)

    M * ERROR tskh_init: db_connect

    M *

    M * TIME Thu Oct 11 16:13:24 2007

    M * RELEASE 46D

    M * COMPONENT Taskhandler

    M * VERSION 1

    M * RC 13

    M * MODULE thxxhead.c

    M * LINE 8170

    M * COUNTER 1

    M *

    M *****************************************************************************

    M

    M Entering ThSetStatError

    M call ThrShutDown (1) ...

    M ***LOG Q02=> wp_halt, WPStop (Workproc 1 1324) [dpnttool.c 301]

    -


    I know Error 1017 is LogonFailure Message, but how can i get it work ????

    Please Help

    Chris

    Add comment
    10|10000 characters needed characters exceeded

    • Quick solution:

      Change the password for the user SAPR3 to the default one (sap)

      Once the installation is finished, search this forum or SAP notes on how to setup the OPS$ connectivity.

      There are "hundreds" of messages about it 😉

  • author's profile photo
    Former Member
    Oct 16, 2007 at 10:14 AM

    Exit Code from ..\sapdba: 2.

    means sapdba.exe was not found.

    I assume that you used the wrong Kernel CD.

    peter

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      aha,

      but this is not a database we are going to create.

      I can not identify any SAP typical database user.

      Did you run an MCOD installation?

      Are there other database instances running on this box?

      A standard installation looks similar to this:

      SQL> select username from dba_users;

      USERNAME

      -


      OPS$WSI64061\D020904

      OPS$NT5\SAPSERVICENX0

      OPS$NT5\NX0ADM

      SYS

      SYSTEM

      SAPSR3

      OUTLN

      TSMSYS

      DIP

      DBSNMP

      regards

      peter

  • author's profile photo
    Former Member
    Oct 16, 2007 at 01:16 PM

    Hi

    Pls see if the below SAP Note helps.

    Note 15626 - SAPDBA: Invisible password for SAPDBA

    Note 50088 - Creating OPS$ users on Windows NT/Oracle

    Regards

    Shaji

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 18, 2007 at 10:40 AM

    Hi Christian,

    If you are trying to install a domain installation then check the password at domain level for sapservice user if that is lock due to fail logon attempts then it fails at 91% i have faced these isses recently.

    Regards,

    iqbal

    Add comment
    10|10000 characters needed characters exceeded