Skip to Content
author's profile photo
Former Member

Data source enhancement

Hi,

I am enhancing a data source.

When am ding the extraction, for a field(rout) am getting blank value.

When i extract a data source by giving single value(vbeln) then code is working fine.DAta is popultaing correctly.

Basically my logic in program is am getting a value for the field "rout", "Vbeln" from table LIKP.

For this am comparing Reference document number(VGBEL) form vbrp table.

So vgbel from vbrp = vbeln of LIKP table.

For the above logic. i wrote this code.

" IF NOT i_vbrp[] IS INITIAL.

SELECT vbeln route bolnr

FROM likp

INTO CORRESPONDING FIELDS OF TABLE i_likp

FOR ALL ENTRIES IN i_vbrp

WHERE vbeln = i_vbrp-vgbel.

ENDIF. " i_vbrp[] is initial

"

Could anyone tell me how to overcome my problem and corect this code???

Thanks in advance

Kind Regards,

Shanbagavalli.S

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • author's profile photo
    Former Member
    Oct 11, 2007 at 07:18 PM

    Hi,

    Your select statement looks good. You are getting the values correctly if you extract for a single value. The case may be of clearing the declared variables. If you are using any variables in the loop, try to clear those variables at the end of the loop ( last statement before endloop). That might solve your problem. Hope this helps.

    Thanks and Regards

    Subray Hegde

    Add comment
    10|10000 characters needed characters exceeded