Skip to Content
0

Can't suppress currency symbol

Sep 15, 2017 at 01:41 PM

70

avatar image
Former Member

We are currently in the process of upgrading from Crystal Reports XI (R1 SP1) to SAP Crystal Reports 2016 and wil have to move from OLE DB to ODBC connections in the same process.

Now when I open our old reports in CR 2016 Developer and set the new db connection, I can display the preview and everything works fine.

But when I run our application and the Redistributable Runtime renders the report, I get currency symbols on all our numbers that are stored in a money format on the db.

It never used to do that before and can't seem to disable it.
Format Field gives me the option to hide the currency symbol, but that's already unchecked and, I mean, it already works in the developer preview...

Is there something I am missing?
Or will this just not work and I have to go into every single report, and change every single currency field to a type conversion formula field?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Don Williams
Sep 18, 2017 at 04:05 PM
1

You are using the original release of CR for VS.

Go here and download SP 21, read the whats new also...

https://wiki.scn.sap.com/wiki/display/BOBJ/Crystal+Reports%2C+Developer+for+Visual+Studio+Downloads

Don

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

We have done that, and also used the new 13.0.21 redistributable, and it hasn't solved our problem yet.

I suspect it is the CR Developer's fault, because it also appears with the old CD XI runtime, after I have changed and saved the report in SAP Crystal Reports 2016 Support Pack 3, Version 14.2.3.2132.
Can you point me to a Patch download for that? Because your download pages are confusing the heck out of me... ;)

0
Don Williams
Sep 19, 2017 at 02:17 PM
-1

I removed CR for VS tag and set to BOE .NET SDK

CR for VS is NOT the SDK to use with BOE, it no longer connects to the BOE Servers.

Go to Service Market Place and log in using your S ID and then download the .NET SDK package for your version of BOE.

Remove CR for VS and install the BOE .NET 14.2.3 .NET SDK package.

I cannot give you a link since the downloads are filtered by your support contract.

Share
10 |10000 characters needed characters left characters exceeded
Don Williams
Sep 15, 2017 at 05:49 PM
0

What CR/BOE runtime SDK, .NET or Java are you using?

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

.NET SDK 13.0.0.99

0
avatar image
Former Member Sep 19, 2017 at 03:06 PM
0

Uhm. No. I don't know why you think we're using BOE; we're not. Please change it back for completion, should someone else find this...

But it seems our combined efforts have worked. SAP CR 2016 Developer SP04 (14.2.4.2410) (I got my S ID only today..), together with CR for VS SP21 and the 13.0.21 redistributable solved my problems.

Thanks, and greetings across the pond.

Share
10 |10000 characters needed characters left characters exceeded