Skip to Content
avatar image
Former Member

An error occurred while invoking the R environment through JRI

Hi,

I installed PA on my laptop recently, and encountered error when trying to run R algorithms.

I have tried two approaches for R installation, but neither worked. The first is to have R installed within the software. However, the downloading process seemingly stagnated. I have tried to change my network settings but could not get it started. The second is to manually install R and configure it within the software. However, after I clicked "OK" button on the configuration page, nothing responded, and the algorithms still could not run, with error message "An error occurred while invoking the R environment through JRI".

The R version I tried to manually install is 3.4.0. The PA version is 3.2.1. Please help me out.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Sep 18, 2017 at 06:32 AM
    Add comment
    10|10000 characters needed characters exceeded

    • Hi James,

      I'd recommend updating your R installation to 3.4.0, since older versions had package compatibility issues which was one of the main drivers to move to 3.4. Also, make sure the Java version you have is up to date and PA is using the right version (JAVA_HOME).

      Let me know how you get on with these two checks and I'll suggest further steps if the issue persists.

      Regards,

      Jayant

  • Sep 19, 2017 at 11:59 AM

    Looping Jayanta Roy and Amit Mathur if they have a clue to share. Thanks guys, Antoine

    Add comment
    10|10000 characters needed characters exceeded