Skip to Content
0

Custom application not working in launchpad after upgrade

Sep 15, 2017 at 05:06 AM

182

avatar image

Hello,

We did an upgrade from 1.28 version to 1.38 version for UI5. On 1.28 all our custom UI5 applications were running correctly. But after the upgrade, only 1 of our custom application is not running. We get the following error.

After checking the errors in the console tab, i came across the following

Error

Error: resource undefined could not be loaded from /sap/bc/lrep/content/~20170914052810.3024250~/apps/fortron.jaarplan/app/sap/z_jplan_app1/manifest.appdescr. Check for 'file not found' or parse errors. Reason: Forbidden at Object.error (http://vbgsapvgd01.vebego01.local:8000/sap/bc/ui5_ui5/ui2/ushell/resources/~20170801141500~/sap/fiori/core-min-0.js:92:35109) at p (http://vbgsapvgd01.vebego01.local:8000/sap/bc/ui5_ui5/ui2/ushell/resources/~20170801141500~/sap/fiori/core-min-0.js:75:25152) at Object.fireWith [as rejectWith] (http://vbgsapvgd01.vebego01.local:8000/sap/bc/ui5_ui5/ui2/ushell/resources/~20170801141500~/sap/fiori/core-min-0.js:75:26003) at h3 (http://vbgsapvgd01.vebego01.local:8000/sap/bc/ui5_ui5/ui2/ushell/resources/~20170801141500~/sap/fiori/core-min-0.js:75:77625) at XMLHttpRequest.<anonymous> (http://vbgsapvgd01.vebego01.local:8000/sap/bc/ui5_ui5/ui2/ushell/resources/~20170801141500~/sap/fiori/core-min-0.js:75:81379) at s.E.dispatch (http://vbgsapvgd01.vebego01.local:8000/sap/bc/ui5_ui5/ui2/ushell/resources/~20170801141500~/sap/ushell_abap/bootstrap/abap.js:2:2621) at XMLHttpRequest.X.handleEvent (http://vbgsapvgd01.vebego01.local:8000/sap/bc/ui5_ui5/ui2/ushell/resources/~20170801141500~/sap/ushell_abap/bootstrap/abap.js:2:3737) at XMLHttpRequest.h [as _fnHandler] (http://vbgsapvgd01.vebego01.local:8000/sap/bc/ui5_ui5/ui2/ushell/resources/~20170801141500~/sap/ushell_abap/bootstrap/abap.js:2:3996) sap.ushell.services.Ui5ComponentLoader

I checked SCN for such issue and it say that the SICF node "/sap/bc/lref/" should be active. I tried activating the node, but i receive the same error. Also some talk about autorization for the folder. I am not sure what they mean by that.

Any ideas , what could be wrong here ?? Nothing was changed in the UI5 component. The app is still working correctly on our quality system, where we are still on 1.28.

Rgds

Sanket

capture.png (11.9 kB)
capture1.png (133.8 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Sanket Chimalwar Sep 20, 2017 at 09:25 AM
0

Issue resolved.. sap.m.route.RoutematchHandler is deprecated from V1.28 and was causing problems in the component.js file. instead used sap.m.route.Router.

Share
10 |10000 characters needed characters left characters exceeded