Skip to Content
avatar image
Former Member

Sender file adapter - filename containing * does not work

Hi All,

I am doing simple file-file scenario wherein my filename is something like

MATMAS05_XI20070911-150159-088.xml

there are many files having similar kind of name which are supposed to be picked

so simply I can go on writing <b>MATMAS05_XI*.xml</b> in filename

it is not working.. communication monitoring gives error <i>Error occurred while connecting to the FTP server "10.25.117.237:21": java.lang.NullPointerException</i>

But when I use character '?' then it works fine - '?' placeholder for each extra character

I am on SP 20.My adapter is configured properly. FTP server working fine with '?' or simple filename. So bit confused why it is not working with *

Are there some BASIS settings which have to be in place to work it out with * ?

All your inputs are welcome !!

Thank You,

Mugdha kulkarni

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Oct 09, 2007 at 02:34 PM

    Hi,

    Have you do a simple test?

    - IP is recheable?

    - FTP port is open?

    - Have you perrmissions to write in target?

    Regards.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 09, 2007 at 02:35 PM

    Try using *.xml.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 09, 2007 at 03:11 PM

    Hi

    this error is not related to multimple files or sending with the * char.. you can use it

    see the below link

    /people/mickael.huchet/blog/2006/09/18/xipi-how-to-exclude-files-in-a-sender-file-adapter

    The error related to the server connection.. also check the ip address is correct or not you configured correctly or not..

    also clarfity the correct error description ..

    Chilla

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Chandra,

      I have gone through this bog. I even tried doing according to this blog .. still it is not working

      My FTP Server parameters are fine. I have all permissions to FTP folder.

      When I specify simple file name, adapter picks the file.. but does not work with *

      Am I supposed to do something on BASIS front?

      Thanks

  • avatar image
    Former Member
    Oct 09, 2007 at 03:35 PM

    Kulkarni,

    Go to command prompt and login to your FTP using the user name and pwd. If you are able to login then you should be able to get files from XI also else check the permissions.

    Regards,

    ---Satish

    Add comment
    10|10000 characters needed characters exceeded