Skip to Content
avatar image
Former Member

ESS only showing empty pages

hi,

i have installed ESS for our portal (7.0) and backend system is ECC 6.0.

when i log on with a user into the portal i can see the ESS menu. but when i go 'deeper' and want to call for example 'Employee Search' i got a EMPTY page, no error.

what can be wrong ?

reg, Martin

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

8 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 12, 2007 at 06:21 AM

    Hi Martin,

    Check for the permissions for the User.

    Also there might be some back end configurations missing.like the user should be created in the backend.

    For more clarifications please revert.

    Thanks,

    Anish

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      rahul,

      i also have solved the problem yesterday.

      problem was that i had the wrong version of the PCUI !!!! i installed

      the 100-version, not the 600-version. Unfortunately even SAP did not

      see this, i made a OSS concerning this issue. I found it myself

      not its working fine 😉

      best regards, Martin

  • avatar image
    Former Member
    Oct 10, 2007 at 04:15 AM

    Hi Martin,

    Most likely, the user is missing permissions for viewing the iviews.

    Please check if the user has at least End User permissions for the standard objects..

    (Open object->permissions->EndUser check box).

    Regards,

    Kshitij.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 10, 2007 at 05:10 AM

    Hi Martin,

    Have you deployed the sca files properly?

    Check this:

    blank-page-showing-for-ess-iview-in-portal

    Regards,

    Shyam.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 10, 2007 at 08:27 AM

    hi there,

    i have downloaded the following files and deployed all of them.

    SAPESS10P_7-20000512.zip

    PCUIGP017_0-20000568.SCA.zip

    BPERP5ESS10_0-10003288.SCA

    i have granted permission with group 'everyone' in the iviews.

    still the same 😔 empty pages.

    when i do 'preview' in the iviews i got a java-error, i post it here.........i am new

    to portal and java, so i don't understand the error:

    500 Internal server error

    The initial exception that caused the request to fail, was:

    com.sapportals.portal.prt.runtime.PortalRuntimeException: Failed to lookup External Link for: portal_content/com.sap.pct/every_user/com.sap.pct.erp.ess.bp_folder/com.sap.pct.erp.ess.iviews/com.sap.pct.erp.ess.personal_information/com.sap.pct.erp.ess.at/com.sap.pct.erp.ess.fam/com.sap.pct.erp.ess.fam

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Martin,

      Please check whether you can find the ESS contents in the Webdynpro Content Administrator. Goto http:// :50000/webdynpro/welcome -> Content Administrator -> Deployed Content -> sap.com. Here, if you have deployed the SCAs properly, there will be contents starting with sap.com/ess. Pls check it.

      Regards,

      Shyam.

  • avatar image
    Former Member
    Oct 10, 2007 at 09:10 AM

    Shyam,

    yes, i have already checked this and it looks okay. what else can

    be the problem ?

    reg, Martin

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Martin,

      There is a property named 'System' in the iview's properties.Here you have to provide the system alias name you specified for the system. Usually for ESS applications, the system alias name should be SAP_WebDynpro_XSS.

      Regards,

      Shyam.

  • avatar image
    Former Member
    Oct 10, 2007 at 09:53 AM

    sorry, there is NO "There is a property named 'System'"

    i have a german language system here, but i can't anything that sounds like 'System'..........i think you are talking about a old version ? i use a 7.00 Portal here ! what is the entry above and under it ? maybe i can find it that way

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Martin,

      In the 'Property Category Editor' dropdown, select 'Content - WebDynpro'. There you will find it. It is the one just above the property 'Web Dynpro Definition Type'.

      I think, before doing this, you just check the alias you have specified for the system. Just give 'SAP_WebDynpro_XSS' there and try again.

      Regards,

      Shyam.

  • avatar image
    Former Member
    Oct 10, 2007 at 10:12 AM

    sorry, the only entry there is called

    Customer exits für 'ParameterProvider'

    it is in german language. that can't be the right field ???? even when i put the SAP_WebDynpro_XSS in there it does not work.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      Please assign read permissions to the entire ESS folder in the Portal content. Try again and if it does not work, also try restarting the Portal server once.

      Thanks.

  • May 14, 2014 at 03:06 PM

    Dear RJ,

    I couldnt find in maketplace these files , for EHP1 NW7.31 and EHP6 FOR SAP ERP 6.0 (backend)

    Could you please help me to find in marketplace to download them ??

    For ESS you need to deploy 3 files:

    1) BPERPESS*

    2) ERPESS07*

    3) PCUI*

    Add comment
    10|10000 characters needed characters exceeded