Skip to Content

Getting "There is no editor available for '***.rpt'." error in VS 2017 with SP 21

Sep 13, 2017 at 08:50 PM


avatar image

I'm upgrading Crystal Reports for Visual Studio from SP 14 to SP 21

My environment:

  • OS: Windows 10 Professional 64-bit, v 1703, Build 15063.608
  • IDE: Visual Studio 2017 Update 3, v 15.3.4

Steps to reproduce:

  1. Uninstalled Crystal Reports for Visual Studio SP14 and 64-bit library
  2. Ran CRforVS_13_0_21.exe as Administrator. Allowed setup to complete and install 64-bit libraries
  3. Opened existing C# project in Visual Studio 2017, and updated project references to library version 13.0.3500.0
  4. Built project
  5. Double-clicked a Report.rpt in project
  6. Received error message stating:
There is no editor available for '***.rpt'.
Make sure the application for the file type (.rpt) is installed.

Other things I've tried:

  • Reboot machine
  • Extract setup files from CRforVS_13_0_21.exe into a folder and run Setup.exe as Administrator
  • Repair installation

Can anyone help me resolve this issue?

Thank you,


10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Don Williams
Oct 04, 2017 at 09:40 PM

Note indicated if you install over a previous version to do a repair install. Uninstall SP 14 first and then install SP 21, from Programs and Features remove the 64 bit runtime first, then CR for VS SP 14. Try rebooting so nothing is left in memory then.

In your project delete the Assemblies and then add the new 3500 versions back in and it should work.

As for why the Designer is not working it is an ActiveX control, but there are a lot of ActiveX/COM dll's installed so not sure why only that one would fail.

VS 2017 would not happen to be the Express version would it? That is the only version not supported, MS doesn't support plug-ins in Express versions, CR for VS is a plug-in.

Possibly your version of the OS has configuration issues. Is there another PC available to test on?


10 |10000 characters needed characters left characters exceeded
Don Williams
Sep 14, 2017 at 09:34 PM

Hi Chad,

I don't know why, I'm using all the same versions and it works for me. It's the Windows DDE Command that should be selecting devenv.exe which then gets redirected to craxddrt.dll that opens the report in VS IDE.

Close VS and then right click on any rpt file and select Properties. On the General tab first button it says Open with... Click the Change button and browse for more and select Microsoft Visual Studio Version Selector. That should resolve the DDE redirect.

If that does not work try repairing VS and then repair CR for VS.

It could be your AV software may have block some registry updates or registering COM dll's etc.


Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Don,

I tried your suggestions, but I was not able to resolve the issue.

It's still doing the same thing. Interestingly, when I viewed the properties of an .rpt file, the "Opens with" section said something like "Unconfigured". I can't remember exactly what it said now, and I don't know how to reproduce it, because when I view the properties of another file type without a program association, it says "Pick an app". When I clicked the "Change..." button, it said something about Visual Studio 2010, which I do not have installed. I was able to switch it over to Microsoft Visual Studio Version Selector, but it did not resolve the problem.

I repaired VS, rebooted, and then repaired CR for VS. No change.

The only antivirus software that's installed on my machine is Windows Defender. Is that what you're using too?



Apparently your problem resembles mine in the question "SAP Crystal Reports for Visual Studio - SP21 does not accept edit designer.", to which, so far I also look forward to a solution.

Luiz Ricardo

Don Williams
Oct 03, 2017 at 02:41 PM

I don't understand why this is so difficult...

See if this helps you:

New In SP21 Release

  1. Integration with Visual Studio 2017
  2. .NET Framework 4.7
  3. FireFox ESR 52
  4. Addressed 10+ customer Incidents.

We still support .Net Framework 3.5 SP1(except the ADO.NET case #5)

Below items should be highlight for SP21:

1. FlexNet and In-Place Upgrade does not work: Once user receive the update notification from FlexNet server and finish SP21 upgrade, the product will NOT work. User MUST repair CR4VS and CRRuntime64 in Control Panel\Programs\. That’s a by design change to installer.

a. Please notice that we are still facing problems on configuring FlexNet upgrade server, so currently user will NOT receive SP21 notification

2. Microsoft Windows Update KB2999226 is a prerequisite for SP21.

a. This is same as BI 4.2 SP4 and BI 4.1 SP10. Please refer to SAP Note 2451830.

3. For VS2017 integration, user needs use “run as Administrator” by right-clicking setup.exe, even if you are already log on by using Administrator account

4. As most of CR/RAS .NET Assemblies are now re-versioned from 13.0.2000.0 to 13.0.3500.0, user MUST remove all old CR assemblies from Reference list and add the new version of CR assemblies, then rebuild the application.

a. For those customer/user who do not wanted to rebuilt their application, there’s workaround to use <dependentAssembly> in app.config/web.config, please see attachment.

5. For reports using the ADO.Net DB connection, in previous SP's, you could only work under .Net Framework 2.0/3.5, so using in app.config is required. Now in SP21, ADO.Net is only supported on .Net Framework 4.0 or above.

For Installation issues PLEASE see this KBA - 2536330 - In-place (FlexNet), MSI and Merge Modules upgrade from Crystal Reports for Visual Studio SP xx to SP 21 does not work

nt6qs.png (68.0 kB)
Show 1 Share
10 |10000 characters needed characters left characters exceeded

I've carefully read and considered every point in that article. I've attempted everything that applies to my situation.

Have you tried upgrading from SP14? Is it possible that there is an issue specifically relating to an upgrade directly from SP14 to SP21?