Skip to Content

ISU Equipment Location is not updated

Hi,

We have a situation where we install two devices to the same device location using FM ISU_S_WORKLIST_INSTALL.

For the first device the Location is appearing in 'Location tab' of IQ03.

But for the the second device the Location is not appearing in the Location tab of IQ03.

We use the same code to update both.

One difference we noticed is that in ILOA-STORTI, the value is 'R' (Data transfer from reference object) for the first device, and 'D' (Field maintained directly. No data transfer) for the second device. And we are not passing this anywhere in the FM call.

Can anyone let us know how this R / D is determined? Is there any configuration or any default template being used by SAP?

Thank you.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Sep 13, 2017 at 11:36 AM

    Joshua,

    Go into IE03 for each device and navigate to the Location tab, then use menu Edit-->Data Origin List to determine where the data is defaulted from.

    https://help.sap.com/erp2005_ehp_05/helpdata/EN/67/79bb53707db44ce10000000a174cb4/frameset.htm

    PeteA

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 13, 2017 at 10:02 AM

    Hello

    While using FM you are passing reference object for both devices ?

    Please maintain the reference object while using the FM.Then check.

    Br

    Rakesh

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 13, 2017 at 07:54 PM

    Even though related to a BAPI rather than FM "ISU_S_WORKLIST_INSTALL", SAP-KBA 1704117 "... updates the data origin fields ... with unexpected values" mentions how the "Data origin Fields" are filled. I'm guessing the same goes for this Function ...

    Add comment
    10|10000 characters needed characters exceeded