Skip to Content
avatar image
Former Member

DB2 Connection Problem


i tried to connect DB2 thru Data servers. Connection is established. It shows as success in Status. but when i tried to open in Query template it doesnt display any tables. but when i check connection in status at this time, it shows as not connected. after this i clicked save button in data server and check the connectivity it shows as success.

it plays like only one connection. ie if i open query template it disconnected but if i clicked save button then it shows as connection successful status.

what is the problem? How to solve it?


Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Best Answer
    Oct 08, 2007 at 12:04 PM


    The DB2 driver is not part of the xMII install in version 11.5 and with 12.0 you need to add all 3rd party JDBC drivers. Assuming you are working with 11.5, you will need to download the version appropriate Type 4 JDBC driver from IBM and copy the jar file(s) to your server: C:\ServletExec AS\se-xMII\webapps\default\Lighthammer\WEB-INF\lib (adjust as needed depending upon your installation). Restart the ServletExec-xMII instance after the files have been put into place.

    You will also need to use the general log for the appropriate error messages that may occur as you get the data server connected and operational, in fact if you look there now I would imagine you will see an error like 'No suitable driver'.

    Also make sure you have a ValidationQuery set in the data server properties.



    Add comment
    10|10000 characters needed characters exceeded