Skip to Content
0

Token verification based on dubbo in receiver SOAP AXIS

Sep 13, 2017 at 02:51 AM

53

avatar image

axis.jpgems.png

Dear all,

I have a requirement which it based on token verification in Dubbo, I used the receiver adapter with SOAP AXIS. The receiver system is below :

	<dubbo:service
		interface="com.ems.framework.web.system.javax.webservice.emsfeedback.EMSFeedBackService"
		version="1.0.0" protocol="webservice" ref="emsFeedBackService" path="ems2FeedBackService" token="123456"/>

I configure the Module of SOAP AXIS, please refer to the attachment in details.

But the error is displayed when I push the data to receiver system.

Error:

MustUnderstand headers: [{http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd}Security] are not understood.

Could you please give me some advice? Thank you for your support in advance.

Many thanks & best regards,

Hubery

axis.jpg (71.9 kB)
ems.png (15.5 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Harish Mistri Sep 13, 2017 at 03:44 AM
0

Hi,

Did you check all the components of axis adapter is installed? please refer the below url to check the components

http://host:port/XIAxisAdapter/MessageServlet

Please refer the below blog for more details

https://blogs.sap.com/2015/08/18/building-axis-framework-package/

regards,

Harish

Show 6 Share
10 |10000 characters needed characters left characters exceeded

Yes Harish, I checked the component, everything is OK.axis-check.png

Many thanks & best regards,

Hubery

axis-check.png (59.4 kB)
0

Hi Hubery,

Can you share the error logs? Do you have XPI inspector installed in the landscape? The XPI inspector logs are very useful to find the exact root cause of the issue. Also, did you tried to connect this Webservice using SOAPUI?

regards,

Harish

0

The attachment is the screenshot of error, I tested it via SOAPUI, I am not sure how to add the token in SOAPUI.

By the way, i am not sure that the configuration is OK or not for the mode of receiving system.

Many thanks & best regards,

Huberysoap-error.pngtoken-error.png

token-error.png (24.8 kB)
0

Hi Hubery,

Few things can be updated in config

1. Update the target url and remove ?WSDL

2. Are you need the assertion ticket? if not then set the parameter Authentication to None for no auth other user name token.

3. Check the WSDL if soap action is required

4. The module parameter hdr is not had the value for user. The user name tocken needs to configure with user.

Please refer the below link to test the user name token with soapui

https://www.soapui.org/soapui-projects/ws-security.html

regards,

Harish

0

Dear Harish,

First of all, thank you for your following, I reply your questions one by one:

1. Remove the ?wsdl.

2. set Authentication to None.

3. No action

4. The receiving system just have token number, there is no username, I think that the token number is just password, so I only configure the password. Maybe I am wrong .

I will check your link to understand different mode for token verification.

Many thanks & best regards,

Hubery

0

Dear Harish,

I check the link, but there is no answer. I will change to other solution to achieve.

Many thanks & best regards,

Hubery

0