Skip to Content
avatar image
Former Member

Screen Painter problem with Matrix

I change the Matrix's properties and it's columns' properties, and I see all the changes in the screen painter. Changes like the editable property or the displaydesc property.

Although I see the editable change takes affect in the screen painter itself, when I open the actual form, it looks like those changes did not take place!

Same goes for column width. I change the width, and it looks fine in the screen painter, but in the actual form I open, the width stays like it was before I changed it!

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Oct 07, 2007 at 01:42 PM

    just wanted to add that the changes also aren't displayed in the screen painter's preview mode.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 08, 2007 at 05:26 AM

    Hi,

    If the changes is not reflected by screen painter,then try it by coding.I have also faced same problem that is solved by coding.

    Thanks & Regards

    Lalit Narayan

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 08, 2007 at 10:36 AM

    Bandel,

    Lalit is rite.Or u can convert the srf File to XML and change their for the particular fields. It will work..........

    Regards,

    Anitha

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 08, 2007 at 05:09 PM

    I prefer a solution by XML and not by coding, because it is just a work-around, and performance-consuming.

    Anyhow, I managed to find the problem - it was the 'settings' property of the form (the property that tells SBO which matrix will show up in the 'setting' button, so it's columns can be managed by the user). it seems that screen painter won't let you have a blank 'settings' property, so it is needed to manually edit the .srf/.xml file and remove the <settings ... /> tag completely from within the <form .... /> tag.

    Add comment
    10|10000 characters needed characters exceeded