Skip to Content
0

SAP Lumira connection to MSSQL 2012 error.

Sep 12, 2017 at 12:01 PM

78

avatar image
Former Member

Hello experts ,

We have an issue with a customer who uses SAP Lumira 1.31. When we try to connect to the MSSQL we get the following error:

lumira-error.png

We have added the JDBC Drivers v4.0 for MSSQL 2012 by adding the sqljdbc_4.0.jar file from the preferences of SAP Lumira, and we unistalled the java from the server.

The only java there is on the server is from the SAP Server Tools, on path:"C:\Program Files (x86)\SAP\SAP Business One ServerTools\Common\sapjvm_8\jre\bin".

Kind Regards ,

Ifigeneia Koumbarda

lumira-error.png (4.5 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Luis Darui
Sep 12, 2017 at 07:02 PM
1

That depends on the driver version you're using.

Driver version 4.0, with JDBC 4.0 (sqldbc4.jar) can only be used up to SQL Server 2012 and runs on JVM 1.6.

Driver version 6.0, with JDBC 4.0 (sqldbc4.jar) can be used up to SQL Server 2014 and uses JVM 1.6 or 1.7.

Driver version 6.0, with JDBC 4.2 (sqljdbc42.jar) can be used from SQL Server 2008-SQL Server 2014 and uses JVM 1.8 (which is, by the way, the same of yours).

Now, you should consult with the Lumira support which driver you can use with SQL Server with your product version, that is the best option.

Share
10 |10000 characters needed characters left characters exceeded
Denis Konovalov
Sep 12, 2017 at 01:36 PM
1

Looks like you need to either upgrade Lumira or downgrade your jdbc driver.

Show 3 Share
10 |10000 characters needed characters left characters exceeded

That would be understandable if Lumira requires a specific JRE to run on.

0

Lumira comes with all the java it needs.
the error means that the java lumira is using is older than the one used to create this jar file (JDBC) driver.
Since we can't manually change Java used by Lumira, it is the driver that needs to be changed.

JRE installed on the machine is irrelevant.

0

sapjvm8 would require Driver 6.0 with JDBC 4.2 API (I just added in my reply). Not sure whether Lumira does support JDBC 4.2 API

0