Skip to Content

ABAP 7.51 Trial: Runtime error DBIF_REPO_SQL_ERROR when navigating Products in Fiori Launchpad

I have successfully installed the new NW AS ABAP 751 SP02 as detailed out in the blog. Thanks!

But I have noticed a few issues with this new install - I wonder if I'm the only one facing these issues with the new server. I'll try to detail out my findings over a few questions.

Issue #1: Error navigating 'Manage Products' tile in Fiori Launchpad (/UI2/FLP)

Steps to reproduce:

  1. Login with user DEVELOPER Client 001
  2. Launch transaction /UI2/FLP
  3. Click on 'Manage Products' tile (Not the one with '(ext)')
  4. Wait for the first product to load....... and it won't.
  5. Click on other products and you'll see the error message 'This product is no longer available'

Short dumps & System Logs

I looked into the system on SM21 and ST22 and found the following logs related to the error above. I have also included the complete log as PDF links in this question - https://drive.google.com/open?id=0B-C3jpSmiGEjZVRSaVAzLU9GWFU

ST22 - Runtime error DBIF_REPO_SQL_ERROR

SM21 - System Log error

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Nov 20, 2017 at 08:47 AM

    Hi Alban, Yes, I slightly misunderstood your first post - I thought it was all / several tiles, not just 1.

    Anyway, I've tested it, get the same error. Tbh though, I don't think this will be a top priority to solve. But thanks for letting us know.

    Best wishes Julie.

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 25, 2017 at 12:14 PM

    Hi Alban,

    I am having no trouble when I assign the FLP to a role and call it directly:

    http://vhcalnplci:8000/sap/bc/ui5_ui5/ui2/ushell/shells/abap/FioriLaunchpad.html?sap-client=001&sap-language=EN#EPMPurchaseOrder-approve_ext&/PurchaseOrder/300000037

    (Sorry, editor won't let me create a live link.)

    It is possible that the old UI2/FLP is not being maintained any longer. Can you try this please? (I cannot test your procedure as yet, since UI2/FLP is not active in my system, and I am about to leave the office.)

    Best wishes; Julie.

    Add comment
    10|10000 characters needed characters exceeded

    • Thanks for the reply Julie.

      I have tried the link you sent above and it looks like it's the same link that /UI2/FLP will redirect to when executing from GUI.

      Anyway, this error seems to only happen when I click on the "Manage Products" tile on the right. All the other tiles - Purchase Orders Approval, Sales Orders, etc seems to work just fine. It is just this one tile "Manage Products" that I've highlighted in red that seems to have this unique problem.

      And, it's not a huge deal actually - I just find it weird to get the short dump error that says "Connection died while writing to socket".