Skip to Content
0

All Privileges on Pending Status after Initial Load

Oct 14, 2016 at 12:54 PM

112

avatar image

Hi Guys,

I am running a refresh on one of our system, and I have completed all other task and now ready to run the initial load (to load back the users), however after running I am seeing that all privileges are on Pending State. I have confirmed when running a check in idmv_link_ext with filter of mcExecState= '512' and saw a lot of entries.

I understand that the PRIV:ONLY role should first be assigned and as it is on Pending status, that's why all of the other privileges are pending as well.

Want to ask if anyone encountered the same, I saw a blog about processing stuck/pending entries but I don't want to proceed yet with that unless I know what might have been happening.

Job logs don't point as well to anything relevant.

Hope someone can shed me some lights. Thanks a lot!

PS. I have searched already the audit views but dont see any significant neither relevance for this issue.

We are running in SP9 of 7.2 version.

10 |10000 characters needed characters left characters exceeded

Hi Santi,

In the new SCN community, we work with tags. Please add the tag NetWeaver Identity Management to your post so it is included in the proper space. Thanks!

0
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Santi Obejero Oct 19, 2016 at 12:27 AM
1

Hi Steffi,

No problem at all, I found out on further investigation that the version of the initial load that we are using is from a lower version. What I did is upload the one from the latest SP9 pack the initial load job. I have as well saw that the constants HR_STAGING_AREA_IDS_ID and SAP_MASTER_IDS_ID needs to be updated as we have deleted the old IDS and uploaded the one we are using in Production (we are doing a refresh of our QA system due to corrupted provisioning frameworks and we are utilizing quite some lists of custom scripts and tasks in the PF).

Really need to be keen of constants and versions of task/jobs that are running in before doing and during the upgrade.

Thanks!

Regards,

Santi

Share
10 |10000 characters needed characters left characters exceeded
Deva Prakash B Oct 20, 2016 at 09:29 AM
0

Hi Santi,

can you kindly please let us know whether you have assigned the priv:repository:only to the users already or haven't as per your statement.

"I understand that the PRIV:ONLY role should first be assigned and as it is on Pending status, that's why all of the other privileges are pending as well."

If not assigned, please try to assign the only privilege now the provisioning tasks would trigger and change status. If already only privilege is assigned, then i suggest you to please look into mxp_provision table/mxpv_provision view and search by user mskey and check if it is waiting for any task to run.

Regards,

DP

Share
10 |10000 characters needed characters left characters exceeded
Santi Obejero Oct 18, 2016 at 10:00 AM
0

Hi Matt,

Thanks, I was able to fix this. I will add the correct tag next time. :) Thanks a lot.

Best Regards,

Santi

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hello Santi,

would you please share with the community how you fixed this. You know: Sharing is caring. ;)

Then mark your answer with the solution as "Accepted" (little button underneath it). That way others can find it better.

Regards,

Steffi.

0