Skip to Content
author's profile photo Former Member
Former Member

iView Personalization - HTTP 400 Error

Hi,

When I try to personalize any of the iViews I get HTTP 400 - Bad Request error.

When I try logging in to portal by-passing IIS (version 6.0) using the port, the personalization works fine. I am sure the issue is with some IIS settings for Portal. I have also checked the Registry Key Value for UrlSegmentMaxLength and is fine.

Could someone let me know which parameter is causing me the trouble.

It would be of great help for me.

Thanks in advance,

Mani.

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Best Answer
    Posted on Oct 03, 2007 at 03:35 PM

    Hi Mani,

    Check this thread it might help...

    /message/157305#157305 [original link is broken]

    Regards

    Juan

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 04, 2007 at 11:16 AM

    Thanks Juan.

    I checked the thread and I added up one more Registry Key: UrlSegmentMaxCount DWORD 4096. UrlSegmentMaxLength DWORD 4096 was already present. But even after a reboot of the server, the issue persists. I am following up with an OSS mesaage too, but no solution yet from SAP.

    Mani.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Mani,

      I have fixed my problem, maybe i can help to fix yours, too.

      I have used fiddler to analyse the https requests an found out that these requests are much more longer than with Fire Fox.

      309 against 162 characters between to /.

      Uwe

  • author's profile photo Former Member
    Former Member
    Posted on Nov 21, 2007 at 11:29 AM

    Hi,

    have you tried to use Mozilla Firefox instead?

    My configuration:

    BI System as Content Producer(SPS13)

    NW Portal as Content Consumer(SPS13)

    No problems with Mozilla Firefox but HTTP 400 Error with IE7 while getting iViwes from the producer.

    Have you found a sollution?

    Best regards,

    Uwe

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 22, 2007 at 12:50 AM

    Hi,

    Thanks for your input. Finally I manged to solve the issue by implementing SP Nego. As I had Personalization issue only when I used IIS, I decided to go with SP Nego implementation which resolved my issue.

    Thanks again,

    Mani.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 22, 2007 at 12:51 AM

    Solved by implementing SP Nego.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.