Skip to Content
0

FIORI Inbox Items Count Error

Sep 11, 2017 at 10:10 AM

152

avatar image

Hi all, you're looking great today! :D

My FIORI Inbox Tile, when counting the entries in my Inbox, goes to the following address:

/sap/opu/odata/IWPGW/TASKPROCESSING;v=2;mo/TaskCollection/$count

followed by a filter... the error occurs with/without the filter, so I've left that out for now.

This returns the following error:

Data Provider implementation 'ZTM_TGW_SVC_MODEL_0002_BE' '01' 'DEFAULT' does not exist

In /iwfnd/maint_service /sap/opu/odata/IWPGW/TASKPROCESSING;v=2/TaskCollection/$count

(i.e. the same as the FIORI tile uses, but without the ;mo in TASKPROCESSING;v=2;mo/TaskCollection/$count)

I get a response with the correct number of workitems.

SO:

My thinking is that either there's a setting within the frontend that adds the "MO" to the request, for some reason, and I can turn that off in the frontend or there's a setting within the backend that can be set to expect to receive the MO, and act accordingly.

Can anyone point me at some documentation as to the cause and purpose of the "MO"?

Thanks for any help.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Patrick Dean Sep 11, 2017 at 01:09 PM
2

Okidoki, my bad, looks like this is down to having 2 system aliases against the service in IWFND/MAINT_SERVICE, one of which doesn't work. MO = "Multiple Origin" (as in, we might have workitems in inboxes across S4/SRM/CRM maybe).

So I removed the alias that didn't work, and I got my answer! Great. Thanks to anyone that took the time to consider this error!

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thanks, it's nice to see someone posting a resolution

1