Skip to Content
avatar image
Former Member

User Authentication Failed via http BUT not with Visual Administrator !!?

OS : Win 2k3 Server UK * DB : SQL Server 2005

SAP Netweaver 2004s Application Java

Hi All,

Since a couple of days, I have a problem concerning authentication to the java apllication on a SAP Netweaver 2004s.

Using the user ¬ĎAdministrator¬í, I CAN logon the Visual Administrator tool, with the same user I tried to logon via http://host:port/nwa without success.

At the beginning, I was thinking about a problem of password then I enabled the emergency user SAP*, the problem was the same. Ok with Visual Administrator but not via http.

Here is two logs found in folder : D:\usr\sap\SID\JC02\j2ee\cluster\server0\log\system\

security.3.log

#1.5#001871E5EA3A00550000006D0000172800043B836D838427#1191335570983#/System/Security/Audit#sap.com/com.sap.security.core.admin#com.sap.security.core.util.SecurityAudit#Guest#0####5aac137070f411dcc513001871e5ea3a#SAPEngine_Application_Thread[impl:3]_11##0#0#Warning#1#com.sap.security.core.util.SecurityAudit#Plain###Guest | LOGIN.ERROR | null | | Login Method=[default], UserID=[Administrator], IP Address=[192.168.10.125], Reason=[Authentication did not succeed.]#

server.0.log

<i>#1.5#001871E5EA3A0052000000130000172800043B835E3661D1#1191335314249#/System/Server/SLDService##com.sap.sldserv.SldServerFrame######c1a349a070f311dcaa68001871e5ea3a#SAPEngine_System_Thread[impl:5]_71##0#0#Warning#1#com.sap.sldserv.SldServerFrame#Plain###Failed to collect SLD data. Failed to send HTTP data: 401 : Unauthorized. Please check if the target SLD system is available and the SLD bridge is started there.#</i>

&#61664; I tried to connect http://host:port/sld same problem User Authentication Failed

<b>Do you have an idea for me? Why a user can connect via Visual Administrator and not via the http interface?</b>

Thanks in advance

Yves

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Oct 08, 2007 at 10:51 PM

    Hello Yves,

    Seems like authorization issue. Assign the user sld roles and then try once more.

    Regards.

    Ruchit.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 09, 2007 at 08:56 AM

    Hi,

    I found the solution this last week-end.

    This behavior let's thinking to a problem of authentication.

    But the problem was in SQL, an index was missing in table J2EE_CONFIG, called J2EE_CONFIG_I3

    Cheers

    Yves

    Add comment
    10|10000 characters needed characters exceeded