Skip to Content

Sometime Sales Order does not appear in MD04

Sep 08, 2017 at 04:59 PM


avatar image

Hello SAP experts around the world,

I am in need of some experts help in one of the on-going Production issue which I am unable to replicate in non-production environment.

The issue is 'sometime Order does not appear in MD04'. Bur Order shows up as soon as I hit ATP check in Sales Order.

We're running program 'SDRQCR21' thru nightly Batch job to remove the inconsistency but that does not do anything to the Order. Order still be missing in Stock requirement list until someone manually goes into Order and hit ATP check.

I tried replicating this issue in non-production systems but no luck so far. This behavior is only limited to MTO Orders and not all orders are effected.

This is sporadic and can be seen in Production every now and then..

The notable thing is ' Order gets created initially thru IDOC using some dummy Material which has CN Schedule line category and later on updated with correct MTO item which changes the schedule line to CP and the item category as well. Not sure if this gives any clue to figure out whats going on here. Please help me figure out what's wrong here..

Thanks in advance,


10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

SP RO Oct 12, 2017 at 11:54 PM

what is the status of that sales order Item (processing and completeness) when it is not appeared in MD04 ?

10 |10000 characters needed characters left characters exceeded
G Lakshmipathi
Oct 23, 2017 at 11:32 AM

As you would accept, for any issue, if it is a repetitive, you can check in either configuration or master data but in your case, it is happening only on sporadically, you need to find out in what circumstances, it is happening. May be, if the issue is related to only one material, then, we can narrow down the analysis to master data related to MRP settings, but on the other hand, if the issue is there for all materials, then, I feel, you need to check in debug mode.

May be, you can have a look at OSS notes 164669 & 1992885. If any of these notes does not give you any hint, then, it would be better to raise an OSS message

10 |10000 characters needed characters left characters exceeded