Skip to Content
0

Transport ADSO -> Composite -> ADSO

Sep 07, 2017 at 02:13 PM

195

avatar image
Former Member

Hi all,

We have a flow: ADSO that loading from composite (HCPR). Composite itself has same ADSO. New fields in all

Attempt of import that flow in target system in one requests led to fiasco. CTS does not form a correct sequence of post-import actions, trying to activate HCPR before ADSO and obviously gives the 12 type error with description like "new fields are absent in ADSO".

I divide transport requests by type of objects: 1. persist objects (tables, cubes, dso) 2. virtual providers (HCPR) etc. And try to import requests in target system. I've tried to import it sequentially and in group. All ways led to 12 error.

With 15 attempts the way had worked out:

1. import request with persist objects without target ADSO.

2. import request with virtual providers

3. import request with ALL persist objects

4. then re-import virtual providers

I think 15 attempts here has played in the end result more than a sequence of actions.

I don't think this is the only and right way of transport this kind of BW flow. Furthermore my scheme doesn't worked in following transport to next system.

So, my question is there any right way of transport this kind of flow ?

System is 7.40 sp13.

BR,

Sergey

adso | hcpr | cts
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
avatar image
Former Member Sep 25, 2017 at 01:25 PM
0

The solution at the moment is to activate problem objects by reports 'RSDG_*_ACTIVATE' between importing requests

Share
10 |10000 characters needed characters left characters exceeded