Skip to Content
author's profile photo
Former Member

Help on SE71...to display field text

Hi gurus,

in my GRN script,i've mentioned the storage location field as mseg-lgort and its coming out properly when executing the print output.....but my client wants to display the text instead of storage location(key)....and it's available in the tran table T001L,field name called LGOBE.

How can i display it in the script(se71) itself instead of my field &mseg-lgort&...

Anyone knows,pls do the needful here.

thanks & regards

sankar

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Best Answer
    author's profile photo
    Former Member
    Posted on Sep 28, 2007 at 10:08 AM

    hi write a perform routine like the following in the SE71 script

    define &w_LGORT& := &mseg-SGTXT&. 
    
    perform sub_get_desc in program ZPROG_GET 
                                         using &mseg-lgort&
                                                &mseg-werks&
                                    changing &w_LGORT&.
    
    endperform. 

    and in the code section write:

    perform sub_get_desc table intab structure itcsy
                                           outtab structure itcsy.
    data: w_werks type werks_d,
             w_lgort   type lgort_d, 
             W_LGOBE TYPE LGOBE. 
    read table intab with key NAME = 'WERKS'.
    
    if sy-subrc = 0.
      w_werks = intab-value. 
      read table intab with key NAME = 'LGORT'.
      IF SY-SUBRC = 0.
        W_LGORT = INTAB-VALUE. 
        SELECT SINGLE LGOBE INTO W_LGOBE 
        FROM T001L WHERE WERKS = W_WERKS AND 
                                      LGORT = W_LGORT.
        IF SY-SUBRC >< 0.
           CLEAR W_LOGBE.
        ELSE.
           OUTATB-VALUE = W_LOGBE.
           MODIFY OUTTAB INDEX 1 TRANSPORTING VALUE. 
       ENDIF. 
      ENDIF. 
    endif. 
    endperform. 

    Hope That Helps

    Anirban M.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      hi anirban.m

      thanks a lot man....u've done it,hat's off!!!

      but even if i remove the code "define w_lgobe& := &sapscript-telenum&"....

      it displaying the record/output exactly man.....

      what's the need for giving this code????....though anyway its working i just want to learn what the use of the code is,thats all!!!!

      thanks alot...

      sankar